[SOLVED] Http post openhab 2.4 failing


I have been working trying to make a z-wave lock linked through the ISY be able to communicate to Openhab 2.4. I made it work with one ISY with version 4.7.3. Using the same network resoruce as attached below.

However, when I tried to replicate this with a new ISY with version 5.0.15A in a different location it started giving me the error “NET MODULE RULE 22: 400”. I’ve been told in the UD forums (ISY994) that it has to do with either the header, body or parth.


I have been able to make openhab control the lock through a HTTP commands to the ISY in both locations. Am I missing something on the header,body or is my path incorrect? All I’m trying to do is change the state of a Switch item from ON to OFF. I’ve created the item in my items folder.

This is what the rest api shows me about the item

If anyone could help with this I’ll appreciate it

Any reason not to use our Z-Wave binding?

On your first screenshot the path looks incorrect it should /rest/items/... (you’re missing the first /).

1 Like

Oh wow, I didn’t think that was it. I’ll change that and give it a try. Thank you so much, this is my error.

Thank you, this was it.

1 Like