[SOLVED] Hue auth error

My Hue system went a little nuts after a recent power outage.
I have the Hue bridge now settled and working from the hue app and from Alexa. I now need to establish the connection back to Openhab, I have removed the thing and rediscovered it and I now need to create the user.
pressing the button on the bridge does not create a log entry I can find for the new user however it is not easy to find in the log that moves so quickly. I find my self questioning two areas, which hopefully someone can answer, I have not found the answer in the binding documentation.

  1. What filter should I use to capture the new user name created?
  2. A simply way to instigate the creation of a new user. I thought it was just press the button on the bridge but it seems there may be other dependancy that I am noty aware of too.



An update.

I have realised for Q1 use the filter ‘user’ or ‘hue’ I will add this to the docs when I have completed the task.

As for the Q2 It seems removing the username completely from the configuration AND then pressing the button on the Hue triggers the creation of the user name.

next issue.

#3. I now have created a new user name and using paperUI thing screen inserted the value into the configuration. I still see the following log entry

User name for Hue bridge authentication not available in configuration. Setting ThingStatus to offline

Two iincorrect tems derived from this log entry. As stated I have added the user name to the config using the Paper UI things screen. secondly the thing does not show offline it shows online.

I checked using the REST interface and it shows the user name is set as the one created in the earlier step.

I will continue to battle my way through but if anyone knows what I am doing wrong please chip in.



Next update.

I checked that I can actually turn bulbs ON/OFF from openhab fine; And then upon checking the onlline/offline status of all my Hue things I see ALL are online like the bridge except for ONE!
This device is actually not a hue bulb, so I removed the thing and the log entry stopped complaining the hue bridge authentication was not in the configuration ceased, seems like the error message was not assisting in this case.

I will check into the thing that seems to be behind the erroneous WARN log entry and pass back.

This has been a frustrating 24 hours trying to get to grips with what has happened. Hopefully this information may help others.

Can I have some confirmations on my findings above from the community experts so that when I update the binding docs I know I am correct and not leading folks astray.



I have checked into the thing that was causing the incorrect log that led me a merry dance.

It is a Sonoff POW module with HUE emulation enabled. I have many of these modules configured in this way but only this one seemed to cause an issue.
I did notice that the IP address it was using was not the one I set in the DHCP fixed DHCP configuration. I reset the moduule and it picked up its correct IP addresss I then removed the two device entrys in alexa and got her to discover once more, it found the device and worked fine turning ON/OFF and also from Openhab basic.

I am really not sure what caused this all but it seems a number of minor issues caused a poor and confusing outcome.

I will happily update the binding doc with the information if someone will confirm my thoughts above regarding Q1 and Q2.