[SOLVED] I really want to use VScode but where is my Samba Share?

Sorry for asking (I hope questions is sort of welcomed in this forum)

I have surfed a little around but what I could find is that there is a default user and password for the Samba share on a newly installed RPI installation. But hm when it doesn’t answer when Browsing from my PC with \ip-adress\ then I wonder what do I miss? I see that it should be setup in the configuration tool as option 66 but where do I find option 66 in the configuration tool? Or is it option 67 ?

  • Platform information:
    • Hardware: RPI 3b+
    • openHAB version: The lastes OpenHabian version
  • Issue of the topic: Samba Share on a fresh install


This is the link that explains about samba share.

The shares are configured to be not open for guests nor to the public. Let's activate the "openhab" user as a samba user and set his password (e.g. "habopen"):

sudo smbpasswd -a openhab

It might be that you have not set a username and password for the share.

Hope it helps

1 Like

Thanks I will read that. But from What I can read the user and password should be configured be default:

Here are the passwords in question with their respective default “username:password” values. All password can be changed from openHABian menu.

  • User password needed for SSH or sudo (e.g. “openhabian:openhabian”)
  • Samba share password (e.g. “openhabian:openhabian”)
  • openHAB remote console (e.g. “openhab:habopen”)
  • Amanda backup password (no default, applied when installing)
  • Nginx reverse proxy login (no default, applied when installing) For manual configuration see here.
  • InfluxDB (No password set by default)
  • Grafana visualization (“admin:admin”)

And I can’t find where to change it in which openHabian menu ?

But again I don’t even get prompted a user and a password when I enter the Samba share into my File explore in Windows

This command is used to set new password for the samba share.

After this try mapping the samba share in your windows computer.
\\192.x.x.x the IP address for your pi which runs openhab

Go to your Windows Credentials and delete any saved username and password for that samba share. After that you should get prompted again.

Thanks but there is no windows credentials saved for samba login. What I really can’t figure out is that I usual never have problems connecting to shares. For me it seems like the service is not started or configured in OpenHabian latest version RPI install. I have now moved from HassIO to OpenHab and I’m struggling with fundamental things that I didn’t expect - I have setup samba shares on RPI before (I will figure it out again if it necessary) but then I would have expected that it was on the “to-do-list” of setting up a new OpenHab installation and that I didn’t see or maybe I have missed some documents.

Exactly that is what I expect to use for connecting to my New installed OpenHab (OpenHabian) on my RPI. But hm. something is not working.

Have now tried reinstalling Samba Share and now I found samba setup option 66 in openhabian-config - couldn’t see the option due to resolution of putty screen. But it did not do any difference - I can see that /etc/samba/smb.conf is updated with OpenHab setup.

I pressed: sudo service smbd restart afterwards but still I cannot get in contact with my Samba share.

For others having the same problem:

Try to make a letter-share to the ex. Z:

Then I got this error:


Then checkmark “login in with different user” and then enter user like this:


In Windows 10 the SMB is disabled on windows updates, evertime windows does an update it appears it disables the old SMB sharing optionand you loose the access to the SMB Shares via windows 10.
You Need to re enable SMB V1 in windows
Follow this link shows how to re enable SMB v1

SMB v1 Windows 10 fix

1 Like

Thank you very much I will take a look at this.

This solved my problem!