[SOLVED] I see no HABPanel

openhab2
setup
habpanel
Tags: #<Tag:0x00007fe05ebf6fa8> #<Tag:0x00007fe05ebf69e0> #<Tag:0x00007fe05ebf6670>

(Michael) #1
  • Platform information:
    • Hardware: Raspi3
    • OS: latest
    • Java Runtime Environment: 1.8.0_152
    • openHAB version: 2.2 stable
  • Issue of the topic: no link to HABPanel
  • If logs where generated please post these here using code fences:

Hi guys,

when I go to my “homepage” (:8080/start/index) I only see these items

  • Openhabian Help
  • Basic UI
  • Paper UI
  • HabMin

but I do not see the HABPanel as described in the docu. I also do not have an entry in PaperUi/Configuration/Services/UI. There I only see Basic UI.

It was available some time ago. I did this inbetween

  • updated from 2.1 to 2.2
  • installed some additional packages via openhabian-config

Does anyone know what I did wrong?

Thanks.


(Nicolas Häffner) #2

is it even installed?
Go to Paper UI --> Addons --> Userinterfaces and check if it is installed :wink:


(Michael) #3

Hi Nicolas,

that’s one other thing. There is no “userinterface” in Paper UI --> Addons. Only

  • Bindings
  • Misc
  • Voice

:frowning:


(Nicolas Häffner) #4

That’s kind of weird…Could you go to Paper Ui --> Configuration --> System and check if “Access Remote Repository” is activated under “Addon Management”?


(Michael) #5

Hi Nicolas,

sorry for the late reply. But I re-installed a fresh new image by now as I also wanted to change to a bigger SD-card.

Now it works like a charm,

Thanks for your time and suggestions.


(Bernhard Peham) #6

I have the similar problem. In the “view” mode I see only a black browser screen. In the “edit” mode I get this:

On my RPI I see the data from the config. Also in the paper UI. Everything looks ok. I guess, that the client can not access to this configuration of my RPI.

Please give me a hint, where I will find the cause of this problem.

Thanks

Bernhard


(Angelos) #7

Your problem is not similar to the OP (he didn’t have HABPanel at all)
You have access to HABPanel but something else is wrong

What do you mean? I don’t think that I got it :slight_smile:
Did you create your HABPanel configuration with all your settings?
Most likely your nginx configs are fooked (I see that you are accessing the URL without 8080)

#3, #9


(Bernhard Peham) #8

Sorry.
I am still a beginner. Therefore I used this area “beginners” of this community.

Thank you for the tip to look in the direction of nginx. I use the habPanel with the same client I made the configuration. And it es real nice. My wife wants me to use our old Windows RT device. But there - and on other clients - I get this boring message …“Server save failed {{error}}”.

Believe me, I tried a lot … and I could not find a solution in this board.