[SOLVED] iCloud Thing cannot be added

Good evening,

openHAB gives me a general SSL engine error when adding the iCloud Thing. Is anyone already fixing this bug?

I haven’t found an issue on GitHub yet.

Would be cool if this could be fixed :wink:

openHAB 2.4 Release Build
iCloud Binding 2.4.0

Kind regards,

This appears to have been fixed over a year ago. Please try in the openHAB 2.5 RC1 version and see if the error reoccurs. If it does we will need to file an issue and need to do so quickly to have any chance of a fix being included in the OH 2.5 release which is happening in a couple of days. See How to file an Issue for details.


Thx for your fast answear @rlkoshak :slight_smile:

I made the Update and my iCloud Account is now online

but unfortunately I don’t get it yet to put my IOS device online.
It is not recognized automatically. Therefore I entered the IMEI number by hand. (see screenshot)

I don’t use this binding so I can’t be of much help with configuration and use.

The docs say it should automatically discover the devices so I would look in the logs and see if there is an error or something like that when you open the inbox and initiate a scan. I will note that there are two Things currently in your Inbox awaiting approval. Are these from this binding?

1 Like

Yes the docs say it but it does not work at all :slight_smile:
The 2 things in my inbox are from other bindings.

2019-12-19 19:59:42.066 [hingStatusInfoChangedEvent] - 'icloud:device:d6e1eefd' changed from UNINITIALIZED to INITIALIZING

2019-12-19 19:59:42.094 [hingStatusInfoChangedEvent] - 'icloud:device:d6e1eefd' changed from INITIALIZING to OFFLINE (BRIDGE_UNINITIALIZED): Bridge not found

2019-12-19 19:59:50.555 [hingStatusInfoChangedEvent] - 'icloud:device:d6e1eefd' changed from OFFLINE (BRIDGE_UNINITIALIZED): Bridge not found to OFFLINE (CONFIGURATION_ERROR): The device is not included in the current account

2019-12-19 19:59:50.660 [me.event.ThingUpdatedEvent] - Thing 'icloud:device:d6e1eefd' has been updated.

The Phone is added to my iCloud Account.

It was not found automatically. I wanted to add it via the IMEI

What can I do? Does someone has the same problem?

Find My iPhone is enabled on your device?

1 Like


Status of the device is now in openHAB 2.5 “Initialising”
But it dont connect to the Account

Also, where did you get that the deviceId is the IMEI?
As the docs says:

A device is identified by the device ID provided by Apple

Has nothing to do with the IMEI. I just looked up my iCloud devices and its deviceId’s are a much longer and ID with numerical and alphanumerical characters in it

ok cool.
Where can i find this specific ID? the binding does not find my mobile automatically…

Restarting openHAB, disabeling the Addon, delete the Account Thing didn´t help.
My browser can also find my phone via the iCloud Web UI.

I think you would need to hit a specific API endpoint to get this ID.
However I think if it doesn’t find automatically, it won’t even work if you enter the correct deviceId.
The iCloud account is still online?
Did you tried pressing the “+” sign on the Inbox and select the iCloud binding and force the auto-discovery again?

days later…my phone is now in the inbox… :slight_smile:

and all items work too :slight_smile:

Thank you for your help guys @rkrisi @rlkoshak :slight_smile:

1 Like

Great! :slight_smile: You need to wait some time to appear… Or force it na the method I mentioned. If you set up family sharing with someone, these will also appear on openhab, you don’t need to set up every account

1 Like