[SOLVED] In development addon - how to run (unresolved requirements)

Tags: #<Tag:0x00007efecf5c1910> #<Tag:0x00007efecf5c1730>

I’ve been looking at the unifi addon - Ubiquiti Unifi Binding Feature Discussion

I think Ive now got it installed,

194 | Installed | 80 | 2.1.0.201704121133 | UniFi Binding

And just managed to figure out a start command of

bundle:start “UniFi Binding”

But when doing this I get an unresolved requirement:

Error executing command: Error executing command on bundles:
        Error starting bundle 194: Could not resolve module: org.openhab.binding.unifi [194]
  Unresolved requirement: Import-Package: com.fasterxml.jackson.core

How can I fix this given I’m just using a jar and not compiling from source?
@mgbowman

Hi psyciknz,

Looks like you don’t have the Jackson bundles installed? I’m not sure how you installed OH2 but you’ll should have the following Jackson bundles:

openhab> bundle:list | grep -i jackson
178 | Active   |  80 | 2.4.5                 | Jackson-annotations
179 | Active   |  80 | 2.4.5                 | Jackson-core
180 | Active   |  80 | 2.4.5                 | jackson-databind
181 | Active   |  80 | 2.4.5                 | Jackson-dataformat-YAML

I installed it from apt-get once it was released as stable.

How do I get those if missing?

I do have the same problem, how can I install the Jackson stuff?

not sure, as you can see I never got a reply as to how to install them, unless we can go apt-get install org.codehaus.jackson

Same here

openhab> bundle:list | grep -i jackson
227 | Active | 80 | 2.4.5 | Jackson-annotations
openhab>

22:59:47.716 [ERROR] [org.openhab.binding.unifi           ] - FrameworkEvent ERROR - org.openhab.binding.unifi
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.unifi [9]
  Unresolved requirement: Import-Package: com.fasterxml.jackson.annotation; version="2.4.5"

	at org.eclipse.osgi.container.Module.start(Module.java:434)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]

Don’t really understand this.

Nobody?

For me adding the JSONPath transformation did the trick. It adds the missing Jackson bundles.

Thank you. This helps :slight_smile:

I have the same problem/error with the UniFi binding, except I have none of the jackson bundles listed at all when I search via grep. I’ve tried installing the JSON transformation with no luck. This is a clean install of OH2 build 938, no other bindings installed yet.

Anyone have anything else to try? @mgbowman ?

Put the following jars also in the addons folder:
jackson-annotations-2.8.8.jar
jackson-core-2.8.8.jar
jackson-databind-2.8.8.1.jar.

Get them from maven. :wink:

That worked, thank you!!