[SOLVED] Including Danalock troubles - commands not accepted

Seeking help after several attempts to add a DANALOCK to openhab2 (using z-wave). The lock will include and is recognized, but no commands are accepted.

Excluded (to be sure); Included; Added as thing; Added items; Triggered inclusion from device only; Restarted Openhab; Re-included (without excluding); Restarted Openhab.

In no situation after adding items, the lock shows any response to the switch. the battery level is available.
No XML is created in /var/lib/openhab2/zwave for the device

Z-wave library 2.2.0 snapshot (from source dated 2017-09-04; installed in addons)
Openhab 2.1.0-1

BTZW125 Danalock V2 circle
Manufacturer: 010e “Poly-control”
Type/ID: 0009:0002
Firmware Version: 0.0
Z-Wave Plus Node Type: UNKNOWN_TYPE
Generic Class: ENTRY_CONTROL
Using Security: ?
Listening: X
Routing, Frequently Listening, Beaming: V

Log level on trace.

NODE 41: ZWaveSecurityCommandClass in verifyAndAdvanceState with newstep=SECURITY_NONCE_GET, currentstep=SECURITY_NETWORK_KEY_SET
NODE 41: payload bytes for incoming security message=00 29 02 98 40
NODE 41: SECURITY_ERROR Device message contained nonce that is unknown to us, id=-20.

After inclusion ends:
NODE 41: Timeout while sending message. Requeueing - 0 attempts left!
NODE 41: Handling failed message.
NODE 41: Got an error while sending data. Resending message.
NODE 41: Too many retries. Discarding message: Message: class=SendData[0x13], type=Request[0x00], priority=Immediate, dest=41, callback=86, payload=29 …

NODE 41: SECURITY_ERROR Invalid state! Secure inclusion has not completed and we are not in inclusion mode. Aborting

Some help is appreciated.

This version of the binding does not support security, so you will not be able to use locks. You need to use the development version - see the link below -:

Oops. My wrong. I thought that the latest in the master was also the security one. All branches in the repo use 2.2.0-SNAPSHOT as version so I assume the branch for this is still not published?

No - it’s not part of the master branch. There’s a binding available in the link I provided above.