[SOLVED] InfluxDB (v 1.0) Persistence not saving

my InfluxDB (v 1.0) Persistence not output any data to influxdb on fresh install openhabian,
I copied old influxdb.persist to openhab, so it shouldn’t be problem, I got no error after openhab startup and running,
just no output, I try use manual way with curl -XPOST -i '
with success, so issue also not on influxdb, influxdb.cfg also configured.

I try reinstall influxdb persistence and got error pop out, I don’t know is this is the issue?? anyone please help~~~~

01:57:43.420 [INFO ] [basic.internal.servlet.WebAppServlet] - Stopped Basic UI
01:57:45.417 [ERROR] [org.eclipse.smarthome.io.rest.sse ] - FrameworkEvent ERROR - org.eclipse.smarthome.io.rest.sse
org.osgi.framework.BundleException: Exception in org.eclipse.smarthome.io.rest.sse.internal.SseActivator.start() of bundle org.eclipse.smarthome.io.rest.sse.
at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:792)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.internal.framework.BundleContextImpl.start(BundleContextImpl.java:721)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0(EquinoxBundle.java:941)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker(EquinoxBundle.java:318)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.container.Module.doStart(Module.java:571)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.container.Module.start(Module.java:439)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:454)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.container.ModuleContainer.applyDelta(ModuleContainer.java:717)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.container.ModuleContainer.resolveAndApply(ModuleContainer.java:491)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.container.ModuleContainer.resolve(ModuleContainer.java:437)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.container.ModuleContainer.refresh(ModuleContainer.java:955)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.container.ModuleContainer$ContainerWiring.dispatchEvent(ModuleContainer.java:1336)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.container.ModuleContainer$ContainerWiring.dispatchEvent(ModuleContainer.java:1)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
Caused by: java.lang.LinkageError: ClassCastException: attempting to castbundleresource://22.fwk20781999/javax/ws/rs/ext/RuntimeDelegate.class to bundleresource://22.fwk20781999/javax/ws/rs/ext/RuntimeDelegate.class
at javax.ws.rs.ext.RuntimeDelegate.findDelegate(RuntimeDelegate.java:146)
at javax.ws.rs.ext.RuntimeDelegate.getInstance(RuntimeDelegate.java:120)
at javax.ws.rs.core.MediaType.valueOf(MediaType.java:179)
at org.glassfish.jersey.media.sse.SseFeature.(SseFeature.java:62)
at org.eclipse.smarthome.io.rest.sse.internal.SseActivator.start(SseActivator.java:44)
at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:771)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:1)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at java.security.AccessController.doPrivileged(Native Method)[:1.8.0_112]
at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:764)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
… 14 more
01:57:45.940 [INFO ] [basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
01:57:46.868 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-persistence-influxdb’: Error restarting bundles

Issue solved,
I finally found I did a little modify by phone today, and as screen too small, while nano save influxdb.persist, it make part of the ignore txt to next line and that makes influxDB not running,
but most funny part is I don’t get ERROR in log:tail, even in DEBUG mode,:rage:

I am also not seeing any data come through, but will now double check my influxdb.persist file and see if I’ve made any mistakes given that no errors are shown.

When trying to re-install the influxdb persistence plugin I get exactly the same error as you. Did you find a way to solve it, or find that you could ignore it?

if you get error while install, just ignore it, it should be a false alarm,
just make sure your influxdb.persist is syntax correct, than restart should everything run,
one thing reminder, I did check with designer on influxdb.persist if my memory didn’t go wrong and didn’t see error on it,
but actually my file have some text start with // which is some description file and 1-2 line was get cut to next line from middle , of cuz the another half don’t start with // and I didn’t aware it when debug


I do issue isolation on following step,

  1. I try restart openhab and look at log, no difference,
  2. than I try remove all the strategy and only set as
Items {

        * : strategy = everyChange, restoreOnStartup

  1. I still fail here than I try set on Persistence default service as influxdb

I still fail here and I got no direction, as I got a spare RPi, and It still got OH2, I was running fine before stop using, than I first turn it on and found it’s influxDB is running, than I copied the influxdb.persist to it and restart, than It also stop having incoming data, than I realize where issue is.

If you don’t need description txt, you may just remove all line start with //, than you will have clearer view of the code

Thanks for taking the time to reply @hamwong - much appreciated. I’ve gone through your suggestiongs, but unfortunately I still don’t seem to be able to get anything to persist into my InfluxDB.

I’ve moved my troubleshooting to the original tutorial thread.

you are right, currently I am on the way to home,
I can’t give details, but I suggest you may take a look here

I start influx by this post and follow as his instruction, mostly it should be works under his step
also I suggest you should open new thread, I am just a newbie, I don’t think I am experienced or skill enough to help you