[SOLVED] [innogysmarthome] Where to find refresh token

Tags: #<Tag:0x00007f616b90d868>
  • Platform information:
    • Hardware: Raspberry Pi 3B
    • OS: Raspbian GNU/Linux 9 (stretch)
    • Java Runtime Environment: OpenJDK Runtime Environment (Zulu8.40.0.178-CA-linux_aarch32hf) (build 1.8.0_222-b178)
    • openHAB version: 2.5.0 Release Build
  • Issue of the topic: Cannot find refresh token in logs

I want to try to update my innogy SHC and had to update refresh token following the description at: https://www.openhab.org/addons/bindings/innogysmarthome/#manual-configuration

To update my *.thing file I enabled TRACE level for org.openhab.binding.innogysmarthome
but I cannot find any entry of refresh token in the logs.

Is there a new way to get refresh token? Adding the authcode to the SHC-thing will stop working after some time (as described in docu).

It looks like the documentation isn’t completely up-to-date. The refresh token doesn’t need to be set on the SHC (bridge). It should be sufficient to set the authCode. The SHC bridge should then go online? Did you try adding the authCode and can you tell what happened?

After adding the code in the *.thing file, the bridge works fine (status: online), but after some time (hours), the bridge switch to error status, which is shown in Paper UI: OFFLINE - CONFIGURATION_ERROR - Cannot connect to innogy SmartHome service. Please set auth-code!

The auth-code is still within the *.thing file but in Paper UI the field of the SHC thing configuration is empty.

Within the logs I have several entries like:

2020-01-14 23:30:50.408 [DEBUG] [ery.InnogyBridgeDiscoveryParticipant] - Found innogy bridge via mDNS:SMARTHOME02 v4:[/192.168.XXX.XXX] v6:[/2002:xxx, /2002:xxx]
2020-01-14 23:30:50.423 [DEBUG] [ery.InnogyBridgeDiscoveryParticipant] - Found innogy bridge via mDNS:SMARTHOME02 v4:[/192.168.XXX.XXX] v6:[/2002:xxxxx, /2002:xxxx, /fe80:xxxx]

All the connected sensors are offline.

It was easier than thought. I only needed to add

Bridge innogysmarthome:bridge:<bridge-id> []

to my *.thing file. Without any parameters within [].

I created a PR to update the docs:

Can someone confirm this works in any case?

For my installation it works now since I noticed it.