[SOLVED] Installation problem: The container is not running

Dear all,
I kindly ask your support in order to install openhab2 (the way to communicate with my Bticino plant is steep yet…).
Here some information, hope someone can help me:

  • Linux mint installation (Ubuntu)

  • Java version:
    openjdk version “10.0.1” 2018-04-17
    OpenJDK Runtime Environment Zulu10.2+3 (build 10.0.1+9)
    OpenJDK 64-Bit Server VM Zulu10.2+3 (build 10.0.1+9, mixed mode)

I’ve installed openhab2 following the documentation but I can only arrive to “sudo /etc/init.d/openhab2 start”, after the OK I proceed wit the “status” and that is the result:

sudo /etc/init.d/openhab2 status
/var/lib/openhab2/tmp/port shutdown port file doesn’t exist. The container is not running.

I tried to go into the tmp folder but I can see only another folder called “instances” with a file “instances.proprerties”.

I also searched in the community and someone solved the problem with a new installation…I am at the 4th installation… :smile:

Thank you for a feedback!


Linux Mint or Ubuntu?

In Ubuntu or Debian based linux use systemctl and services not init.d

sudo systemctl start openhab2.service
sudo systemctl status openhab2.service

sudo systemctl enable openhab2.service to enable start after reboot


Systemctl doesn’t function!.

Thank you for your reply!


1 Like

Thank you Dim for your answer…it works!!!
Hope this post could be helpful for someone else, I installed java 8 using these commands:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer
sudo apt-get install oracle-java8-set-default

Thank you!

1 Like