[SOLVED] Installing homie binding via configuration files

Tags: #<Tag:0x00007f616f86c888> #<Tag:0x00007f616f86c748>

Hello!
I’m running OpenHAB 2.5.3 via docker (openhab/openhab:2.5.3-amd64-debian). I’m attempting to install the homie binding via configuration files. According to the documentation I should be able to locate the binding’s name via the console. However nothing is found named homie…

openhab> feature:list | grep homie                                                                                                                                    
openhab> 

As an alternative, I should be able to discover the name via the URL used in the binding documentation, i.e. https://www.openhab.org/addons/bindings/mqtt.homie/. But using mqtt.homie is not found when openhab starts up. Also tried just plain homie without any luck.

2020-03-29 21:25:02.964 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-mqtt.homie'
...
2020-03-29 21:26:02.922 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-homie'

Help. :pleading_face:

Thanks,
-Chris

Oops, looks like I posted too soon; found a post that referenced the homie binding is a subset of the MQTT binding…

I’ll look at making a PR for the docs to make sure those that find the homie binding by way of Google realize this is a subset.

-Chris