[SOLVED] iOS App - updated icons not taking effect

I spent some time last week playing with some dynamic icons. On and iPad and computer this icon that I’ve altered is now blue. But this phone continues to show a green icon.

How can I force this app to update the icons?

I’ve found that some icons display quite strangely on the iOS app too. They seems to have some odd artefacts associated with them.


which version of the iOS app are you two using?

Your first issue sound like something I encountered as well, I assume you have also tried clearing the icon cache in the setting first, and was a problem with the cache not being cleared correctly.

It was fixed with version 2.3.11

The second issue still seems to be open, and it looks like you’re using svg icons as well

All the best

Hi, am using App version 2.3.1(1580410422). Apologies, I didn’t realise the issue had been covered before. I must have missed that. I am indeed using SVG icons.

Many thanks for the clarification.

I’m on the same 2.3.1. I’ve not see any app updates for a .11 version. I use PNG icons.

You can get the beta versions if you sign up for the TesFlight releases

The latest version there is 2.3.25

Ok I have the test flight version now…it’s fixed the icon issue, but who knows if it’s because I’ve loaded a new version (ie reinstalled) or the updated version.

But at least I can see if there’s anything else. Thanks

The developers who fixed the issue after I reported it in the linked bug above know :stuck_out_tongue_winking_eye: and me who verified the bug with the new version they released.

And you yourself can verify it by making changes to one of your icons again and seeing if the changes get picked up by the iOS app now. Same as when you previously posted here that it didn’t work.

You might also want to have a look in the github release history of all the beta version since your previously installed 2.3.1 to the current 2.3.25, to see what other changes and fixes have been impolemented since.

Either way, if you find any issues with the beta releases, they should be reported with a bug in github, and not here in the forum.

Also marking this thread as solved would be great to contribute to the community forum continuity.