[SOLVED] iOS device won't register so cannot use mobile but OH Cloud works fine in browser

Hi All

I’m struggling to connect remotely using the iOS App through https://myopenhab.org . I have other OH instances that work perfectly but they were set up some time ago.

I can login and control everything using Chrome but not my mobile for some reason. I can see that https://myopenhab.org/devices does not contain any devices and displays the following message:

No Devices
You currently have no devices registered with openHAB Cloud. To register a new device, download the openHAB app and set https://myopenhab.org:443 as the remote URL and your openHAB Cloud login data as username and password.

I’ve tried:

followed by the username and password that I use to login using Chrome but i get a 400 error.

I’ve tried on an iPhone 8 Plus and iPhone 7

I’ve searched the forum and git and found some have had issues but that was some time ago.

Does anyone have any ideas on what the issue may be?

There is obviously some kind of bug somewhere, anyway problem solved.

I completely deleted myopenhab.org account, removed the cloud connector and set it up from scratch using the same username and password as I did before. No luck, same problem.

I then decided to change my password to something else and it worked!

For the remote URL I used https://myopenhab.org (no ports or anything on the end)

By the way if anyone thinks I’m an idiot and probably typed the wrong password or something then that is incorrect as I use a password manager and the password worked fine using a browser just not the App. :stuck_out_tongue_winking_eye:

Hope this helps someone else that comes accross this issue.