[SOLVED]-ish Can't (re)connect to Google Home, started with syncing problems

I have a problem reconnecting OpenHab (2.4.0) to Google Home.
Everything was working fine, I could control my items through Google Home/Google assistant, either through voice command, or through the switches in Google Home.

Suddenly though when turning ‘everything on’ Google notified me it “could not reach 3 lights”
Odd. Oh well, since i wanted to add a new device/item from OpenHab, I thought a “sync” would settle it.
Google then told me that there was an error and I needed to re-link openHab.
Ofcourse I tried first to just restart openHab, but the message stayed. I could sync all my devices, except openHab. “Need to relink openHab” is what Google told me.

So,somewhat reluctantly I unlinked openhab and tried relinking it. I was brought to the myOpenHAB authorisation screen, authorized, and…“Couldn’t update the setting, check your connection”

That got me a bit baffled, my LAN and WAN connections are/seem ok. Google Home can control other items, I can access openHAB through myopenHab.org.
On the forum I saw some people had similar problems in 2018…but didn’t see a solution, other than to lower the MTU in my router…which did not help
I still seem to have access through the Google assistent (with voice commands), but It is not in Google Home anymore
I am lost on this one, wouldn’t really know where to start. Anybody any suggestions?

OK, I think I got it.
The validity checker showed my itemsfile as OK, but showed one item that didnt have a Tag.
Not a big issue I thought, but as I am at it, lets give that a tag.
Then I saw that there was a problem with that line.
Accidentally a Carriage Return had crept into that line. Fixed that…and I could add GH again. Seems fixed.
Ofcourse now I have to do all the naming and adding to rooms again, but it seems fixed

Seems I have induced a new problem. Eventhough the unlinking and relinking of OpenHab in GH failed a few times again…the new problem is that openhab devices just keep being added double and triple and fourfold every time I (re)link -which I thought was the solution to the doubling.
This however seems very much a GH issue. See a lot of people with similar problems