[SOLVED] Issues with Homematic Binding


Homematic Binding stops working when my host gets a second network interface (openvpn in this case). I added and configured CCU2 via PaperUI, and org.eclipse.smarthome.core.thing.Thing.json looks like this:

  "homematic:bridge:ccu2": {
"class": "org.eclipse.smarthome.core.thing.internal.BridgeImpl",
"value": {
  "label": "Homematic Bridge",
  "channels": [],
  "configuration": {
    "properties": {
      "cuxdPort": 8701.0,
      "socketMaxAlive": 900.0,
      "reconnectInterval": 0.0,
      "aliveInterval": 900.0,
      "timeout": 15.0,
      "hmIpPort": 2010.0,
      "wiredPort": 2000.0,
      "gatewayType": "ccu",
      "gatewayAddress": "",
      "rfPort": 2001.0,
      "callbackHost": ""

Now, frequently I get a message like this:
==> /var/log/openhab2/openhab.log <==
2017-05-21 16:42:42.668 [INFO ] [ternal.communicator.HomematicGateway] - No event since 1302 seconds
from gateway ‘ccu2’, restarting RPC server
2017-05-21 16:42:42.805 [ERROR] [ematic.handler.HomematicThingHandler] - Illegal status INITIALIZING.
Bindings only may set UNKNOWN, ONLINE, OFFLINE or REMOVED.
java.lang.IllegalArgumentException: Illegal status INITIALIZING. Bindings only may set UNKNOWN, ONLINE,

Then everything reloads, all Homematic related items get an update, and everything freezes for the next > 900 seconds. I tried to set the ports & Co. manually, but it makes no difference.

Using openhab2 Debian STABLE package 2.0.0-1 on Raspbian 8 (4.9.24-v7+ #993 SMP Wed Apr 26 18:01:23 BST 2017 armv7l GNU/Linux)

$ java -version
java version "1.8.0_65"
Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot(TM) Client VM (build 25.65-b01, mixed mode)

What can I do to get a stable system again? Disabling openvpn is not an option as it is needed :slight_smile:


Hi Mariannne,

I think the problem is caused by your configuration. You have used the same IP address for the gateway and callback host. As callback host you must set the main IP address of the computer where openHAB is running.


Hi Martin,

thanks a lot for this hint! I changed it in PaperUI, and now everything seems to work again. The trick seems to be that I have to manually define callback host and gateway, it was not necessary before using openvpn. If I don’t, my logs get flooded with “more than one network interface - ignoring” messages, and the binding does not connect my ccu2.

Anyways - it works now :slight_smile:


Hi Marianne,

good to hear that it’s solved. I had a similar problem after the installation of VirtualBox and the configuration of a bridge network adapter.