[SOLVED] Items to be exposed (Thermostat) for Google Assistant

Hello all,

I tried to make my heating thermostats usable with Goggle Assistant.
I followed this instruction:


But one thing is unclear for me: I made a goup with 3 Items as mentioned there. But what has to be exposed to the myopenhab Cloud? The group or each singe item within the group or both?

I tried to expose the items and they appear in myopenhab but the thermostat is not recognized by Google Assistant.

In general the assistant integration works, I have some Lighting and Switchable Items which are accessible via Google Assistant

Thanks for your help


The group needs to have the Thermostat tag, the current temperature item needs to have the CurrentTemperature tag and the setpoint item needs to have the TargetTemperature tag applied. Whether you expose them to IFTTT for MyOpenHAB or not doesn’t make a difference.

1 Like


I think I configured it in this way. Here is my Item configuration:

Group   GA_Therm_WZ     "Wohnzimmer Thermostat"     ["Thermostat"]
String   HmIPBWTHWZ_1HEATINGCOOLING                   "Heating Cooling"             (Heizung, Wohnzimmer, GA_Therm_WZ)  ["homekit:HeatingCoolingMode"]  {channel="homematic:HmIP-BWTH:LEQ1010248:000C98A995005D:1#HEATING_COOLING"}
Number   HmIPBWTHWZ_1SETPOINTTEMPERATURE              "Set Point Temperature"       (Heizung, Wohnzimmer, GA_Therm_WZ)  ["TargetTemperature"]           {channel="homematic:HmIP-BWTH:LEQ1010248:000C98A995005D:1#SET_POINT_TEMPERATURE"}
Number   HmIPBWTHWZ_1ACTUALTEMPERATURE                "Actual Temperature"          (Heizung, Wohnzimmer, GA_Therm_WZ)  ["CurrentTemperature"]          {channel="homematic:HmIP-BWTH:LEQ1010248:000C98A995005D:1#ACTUAL_TEMPERATURE"}

Just is case add some spaces
The item file parser can be capricious
Otherwise looks correct

Group   GA_Therm_WZ     "Wohnzimmer Thermostat"     [ "Thermostat" ]
String   HmIPBWTHWZ_1HEATINGCOOLING                   "Heating Cooling"             (Heizung, Wohnzimmer, GA_Therm_WZ)  [ "homekit:HeatingCoolingMode" ]  { channel="homematic:HmIP-BWTH:LEQ1010248:000C98A995005D:1#HEATING_COOLING" }
Number   HmIPBWTHWZ_1SETPOINTTEMPERATURE              "Set Point Temperature"       (Heizung, Wohnzimmer, GA_Therm_WZ)  [ "TargetTemperature" ]           { channel="homematic:HmIP-BWTH:LEQ1010248:000C98A995005D:1#SET_POINT_TEMPERATURE" }
Number   HmIPBWTHWZ_1ACTUALTEMPERATURE                "Actual Temperature"          (Heizung, Wohnzimmer, GA_Therm_WZ)  [ "CurrentTemperature" ]          { channel="homematic:HmIP-BWTH:LEQ1010248:000C98A995005D:1#ACTUAL_TEMPERATURE" }

I added the blanks…
So far the Google Assistant does not recognize a new device. Maybe it takes some time, let’s see…

Did you restart OH?

no, so far. Takes some effort since OH always “forgets” the security code for my Trädfri Gateway when I do so :thinking:
I’ll try it later…

I restarted the OH service.
Did not help. Thermostat is still not visible in Google Assistant…


Did you add the openhab skill to the google assistant?

Did you ask Google to sync your devices? “Hey Google, sync my devices”, should result in a reply like “Ok, syncing devices for Openhab”.

1 Like


I wasn’t aware about this command. It worked!
All configured Thermostats are available now!

Thanks a lot!


Hello guys,

I managed to get the thermostats working in my GA.
Only got 2 more issues:

  • heating/cooling mode cant be set from GA, does update when changed from basicUI (could this be because i dont have a physical thermostat, only items. Software thermostat so to speak)

  • Current humidity doesnt show up anywhere (might not yet be supported)

Im writing this on my phone, soon as i get home i will include items files :grin:

See the Thermostat example in the docs. https://www.openhab.org/docs/ecosystem/google-assistant/

You need to create a Group tagged as Thermostat and add all the thermostat Items to that Group. It isn’t required for current temperature but it is required for the other Items, including humidity.

And the comment in the example indicates you need to define an Item to represent the mode whether or not you use it.

Hi Rich,
Thanks for your response.

This is my items file:

Group GF_KidsRoom_Thermostat "Thermostaat kinderkamer" [ "Thermostat" ]
Group GF_Hallway_Thermostat "Thermostaat gang" [ "Thermostat" ]
Number GF_KidsRoom_HeatingMode "Verwarmingsmode kinderkamer [%s]" (GF_KidsRoom_Thermostat) [ "homekit:HeatingCoolingMode" ] 
Number GF_Hallway_HeatingMode "Verwarmingsmode gang [%s]" (GF_Hallway_Thermostat) [ "homekit:HeatingCoolingMode" ] 
Group:Number:AVG GF_KidsRoom_Temp_Meas "Kinderkamer  gemeten temperatuur [%.1f °C]" <temperature> (gTemperature, GF_KidsRoom, gKidsRoom_Temp_Chart,GF_KidsRoom_Thermostat) [ "CurrentTemperature" ]
Group:Number:AVG GF_Hallway_Temp_Meas "Gang  gemeten temperatuur [%.1f °C]" <temperature> (gTemperature, GF_Hallway, gHallway_Temp_Chart, GF_Hallway_Thermostat) [ "CurrentTemperature" ]
Number GF_KidsRoom_Temp_Target "Gewenste temperatuur kinderkamer [%.1f °C]" <temperature> (GF_KidsRoom, gTemp_Target, gKidsRoom_Temp_Chart, GF_KidsRoom_Thermostat) [ "TargetTemperature" ]
Number GF_Hallway_Temp_Target "Gewenste temperatuur gang [%.1f °C]" <temperature> (GF_Hallway, gTemp_Target, gHallway_Temp_Chart, GF_Hallway_Thermostat) [ "TargetTemperature" ]           
Group:Number:AVG GF_KidsRoom_Hum "Kid's room humidity [%.1f %%]" <humidity> (gHumidity, GF_KidsRoom, GF_KidsRoom_Thermostat) [ "CurrentHumidity" ]
Group:Number:AVG GF_Hallway_Hum "Hallway humidity [%.1f %%]" <humidity> (gHumidity, GF_Hallway, GF_Hallway_Thermostat) [ "CurrentHumidity" ]

At first i made the mistake of not having the homekit binding installed. After installing it i was able to see the thermostats in GA, but i still cant change the heatingmode in GA. When i change the heatingmode in basicUI it is updated correctly in GA. Current temperatures are displayed correctly in GA as are target temperatures. Its allso possible to update targets from GA. However current humidity doesn’t show up in GA.

I beleive i have my items setup correctly but i could be missing something (obvious :grin:). Could the problem be i don’t have a physical thermostat linked to the thermostat items? Allso noticed when i use a current temperature tag on an item that is not part of a thermostat group i dont get any value in GA. But GA does show the widget in heatingmode even if there is no heating mode linked to this current temperature item.

Number testTemp "test temperatuur" [ "CurrentTemperature" ]

Thanks for your time

All I can offer is what is in the docs. Though for humidity it doesn’t show that on GA You have to ask for it. “Hey Google, what’s the humidity in the kids room?” I can’t say why it’s not showing the current temp though.