[SOLVED] Joined a vivint branded CT100 thermostat to an Aeotec zstick gen 5?

Has anyone successfully joined a vivint branded CT100 thermostat to an Aeotec zstick gen 5?

I’ve got an openhab2 system running. It uses an aeotec zstick Gen5 for the zwave controller. I bought a used Radio Thermostat CT100 off ebay, but didn’t notice that it’s a Vivint label.

I can’t get the CT100 to join with the zstick. Even after doing the RT process for factory reset

And even after repeated factory resets, ‘link’ still shows under the radio tower on the display (which, from the RT CT100 docs, indicate that the thermostat has already been assigned (linked) to a controller).

So, has Vivint done their own firmware thing to lock the device to their system? and I’m out of luck with this? Or am I missing something?


I found this over on the smart things forums, could be worth some investigating - https://community.smartthings.com/t/resetting-previously-paired-ct100-thermostat/31497

anonymous.one, thank you. The magic was at the end (reproduced here). my additions are in italics. I have confirmed that this works and my CT100 is joined to the aeotec zstick gen5, and is a thing in openhab2 now. I will do a ct100.item maybe this weekend.

Thanks again.

From https://community.smartthings.com/t/resetting-previously-paired-ct100-thermostat/31497

I did find some instructions that worked. It was buried in one of the Radio Thermostat support pages for a different device. See https://radiothermostat.desk.com/customer/en/portal/articles/2024247-zwave-rtzw-02-module-information.

Here’s the buried verbiage that ultimately worked for me:

Factory Default Restore
Performing a Factory Default Restore will return your thermostat to the state
it was in when it left the factory. This means that all of its configuration and
parameters will be returned to their default values. This includes resetting its
Z-Wave network information, removing it from its previous network. This action
should only be used in the event that the network primary controller is missing
or otherwise inoperable. To perform this action, the thermostat must be switch
to OFF mode. Wait until the radio wave icons these are the lightning bolt looking things to the left of the radio tower. Does not include the tower itself on the left side of the screen stop
blinking then touch the screen once don’t touch it in the middle, touch it somewhere near the edge to turn on the back light and then hold push and keep pushing on the
center of the screen for about 8 seconds until the thermostat beeps. There will be some weird boot looking block lettering. Just set it aside and leave it alone for 5 minutes or so. The regular display will return on it’s own. Look to be sure the ‘LINK’ under the radio tower is gone. If so, then the CT100 is unjoined and you should be able to join another controller using the usual mating sequence described lots of other places, including the manual.