[SOLVED] KNX: switch command does not reach KNX Bus


I am new to OpenHab2 and have done and read a lot by now. My house is all KNX and until now I used OpenRemote. Because of the desire to use Echo Dot Alexa I started up using OpenHab2.

So far I was able to install OpenHab2 on a RPi3, get it running and make a connection to my KNX IP Gateway and trigger a Switch for a KNX address in a valid sitemap. Unfortunately the command does not reach my KNX bus. In the ETS Group monitor the command does not show up.

Item: Switch Living_Table “Eettafel” { knx=“1/1/103” }


I read a lot about ETS line needing to be of type IP not TP. Mine is IP.

What else could be wrong?

OH2 version?
knx.cfg contents?
what device are you using?

Thanks for your fast reply.

OH2 version: OpenHABianPi 2.2.0, at SSH login it states openHAB 2.2.0-1

Knx.cfg now has very little entries:


But actually the knx.config has more entries because I tried a lot so far…

ÓpenHAB log viewer:

2017-12-25 09:22:23.768 [INFO ] [nx.internal.connection.KNXConnection] - Established connection to KNX bus on in mode ROUTER.

Device: Raspberry Pi 3 Model B Rev 1.2 with a KNX JUNG IPS100REG IP Gateway.

Hi Nicokluin,

Have you tried to see if you can send information from KNX to Openhab? (temp, motion etc)
Is the switch defined as a 1bit switch in ETS?

Regards Chris

Hello Chris,

In ETS I had not added anything… yet. I was not aware I needed to add anything there. Could you please point to a ‘how to’ which I can follow to implement this with ETS? I am using ETS 5.5.3.


Nico Kluin

you need to set the real ip of the jung ip interface in the knx.cfg.
you can change the ip in ETS. is only the multicast address.

this is what my config looks like using an ABB IPS/S3.1.1 ip interface:

openhab> config:list “(service.pid=org.openhab.knx)”

Pid: org.openhab.knx
BundleLocation: mvn:org.openhab.binding/org.openhab.binding.knx/1.12.0-SNAPSHOT
ip =
localIp =
service.pid = org.openhab.knx

where “ip” is the ip of the abb interface and “localip” is the raspberry ip.
no more settings needed here.

Hi OIiM,

I changed it and on the log viewer the following appeared:

Unfornately when triggering the lightswitch in the OpenHAB UI I only have it noticed in the OpenHAB log viewer and not in the ETS Group Monitoring.

So it seems something has started to connect but not enough. Any other ideas? Might it be a problem that the OpenRemote is still connected (probably through Tunnel) in parallel? OpenHAB is in ROUTER mode. So I believe these two can work side by side.

OpenHAB config:list now looks like:


Nico Kluin

The IPS100REG is an knx/ip interface, but no knx/ip router, so you have to use TUNNEL mode instead.

The correct configuration should look like

ip =         #this is the ip of IPS100REG
localIp =   #this is the ip of the openHAB server
port = 3671              #default port
type = TUNNEL            #as IPS100REG is an interface, but no router
igonrelocalevents = true #should help against mirrored telegrams
busaddr = 1.1.54         # has to be unused at all in ETS (no busaddr from knx/ip interface!)

Comments are for better understanding, please don’t add comments in the same line as the parameter (though it should work).

Please don’t touch ETS side if you don’t know what you are doing :wink:

Hello Udo,

Thank you for your reply. That did the trick! After a reboot the dining table light gets triggered correctly! So the OpenHAB ETS binding is now working. I even did not have to shut down the OpenRemote instance. So this means the IPS100REG can handle OpenRemote and OpenHAB in parallel, pfff.

Now I can resume configuring the KNX addresses in OpenHAB and learn more about this great product! Is there any way to import the ETS project database? My house is a very big so this is a lot of work…

Thank you all for the help!!

NOTE : if you see a positive message in the log stating ‘Established connection to KNX bus on in mode ROUTER.’, do not believe this. You might think there is a connection but I now learned that this is not true… In my case the Router setting for my ip gateway was invalid. I need to use a Tunnel.


Nico Kluin