[SOLVED] Kodi Binding / Problem with navigation in the UI


I have just done implementing Kodi Binding into my Openhab …

For the control of an film e.g. I use the following part:

Player myKodi_control “Control” (gkodi) {channel = “kodi: kodi: 9e794614-c279-cc63-1a57-44d77855023a: control”} -> this works perfectly

BUT how can I move in the UI? Like up, right, left, down and make a selection (Okay), etc.
… in the documentation of the binding I read something from:


however I do … nothing works with moving in the UI …

Can someone help me … please …

Greetings Henning

Hi Henning,

IIRC left , right , up , down, select, back commands for channel inputaction are what you are looking for. Did you test them?

See also:


yes this is the thing i searched for.

But i did not know how to implement this into my Kodi.items file …
And the URL above you send with your comment … I get an 404 Error

Greetings Henning

Try this link: https://github.com/openhab/openhab2-addons/tree/master/bundles/org.openhab.binding.kodi#channels

@scottk and @cweitkamp:

Yes i see the Dokumentaition about the Kodi Binding …

An i figure out in the example this must be the right thing:

String myKodi_input “Input” { channel=“kodi:kodi:myKodi:input” }

But nothing happens if i put this into my file kodi.items

Greetings Henning

Now you have to put it into a Sitemap - I would suggest to use a Selection Element with a mapping for the relevant Commands - or use a rule to send Commands to it …


i have put the demo example into kodi.sitemap …

I see this works for showing the input … Thanks for that …

But why did the input field wont work i put to my items:

Group gkodi
 "Kodi OPENElec"

String myKodi_input                 "Input"                    (gkodi) { channel="kodi:kodi:9e794614-c279-cc63-1a57-44d77855023a:input" }

The control statement work’s fine:

Player myKodi_control               "Control"                  (gkodi) { channel="kodi:kodi:9e794614-c279-cc63-1a57-44d77855023a:control" }


Greetings Henning

May I ask you two questions?

  1. What OH2 version do you use?

  2. Can you provide an abstract of your Sitemap too?

The example in the documentation uses a mapping for the item bound to the input channel like this:

        Selection item=myKodi_input mappings=[Up='Up', Down='Down', Left='Left', Right='Right', Select='Select', Back='Back', Home='Home', ContextMenu='ContextMenu', Info='Info']


so …

My OH2 Version is: openHAB 2.4.0-1 (Release Build)

And my Sitemap looks so:

sitemap Home label="Home" {
    Frame label="Keller" icon="cellar" {
        Group item=C_Boiler
        Group item=C_Corridor
        Group item=C_Holzlager
		Group item=C_Technik

    Frame label="Erdgeschoss" icon="groundfloor" {
        Group item=GF_Corridor
        Group item=GF_Office
        Group item=GF_LaundryRoom
        Group item=GF_Dining
        Group item=GF_Kitchen
        Group item=GF_Gasteklo
        Group item=GF_Wardrobe
        Group item=GF_LivingRoom

    Frame label="Zweiter Stock" icon="attic" {
        Group item=F2_Bedroom
        Group item=F2_Bathroom
        Group item=F2_Corridor
        Group item=F2_Jan
        Group item=F2_Mark
        Group item=F2_Lukas
        Group item=F2_StorageRoom

    Frame label="Draußen" icon="garden" {
        Group item=OU_FrontYard

    Frame label="Dachgeschoss" icon="attic" {
        Group item=AT_Dachgeschoss

    Frame label="Einliegerwohnung" icon="none" {
        Group item=E_Bathroom
        Group item=E_Kitchen
        Group item=E_LivingRoom
        Group item=E_Bedroom
        Group item=E_Windfang

    Frame label="Garage" icon="none" {
        Group item=G_Garage

Now I see the root cause. The rendering of Group elements in Sitemaps uses the Default element for your defined Items. In OH2.4 your are probably facing an issue which has been fixed with https://github.com/openhab/openhab-core/pull/1009.

Okay nice to hear abou a soulution …
But how to update my System.

I use an Raspi Pi 4 4GB

and i try

sudo openhabian-config

And after updates for openhab and system i reboot the system

the Version number of Openhab is the same aws aboth no 2.5 - 1 ?

how to update ?

Greetings Henning


I have Updated today to stable openHAB 2.5.0 Release Build… And tataaaa … It works now …

thanks alot

Greetings Henning

Nice to hear. You are welcome.