[SOLVED] LG webOS Binding - Can't find television from docker container (host server can find it)

Hi everyone,

for the last weeks I used OpenHAB directly installed on my linux machine. The LG WebOS Binding worked without any actions needed from my side. Last weekend I decided to run my stuff in Docker containers (for “reasons” :slight_smile:). I couldn’t find some things automatically, including my television (55B7D).

Topics in the openHAB-forum suggest to put the container in host-network mode and to set the correct NIC in the settings where i chosed the physical NIC ( Here is an except from my docker-compose.yml:

    image: openhab/openhab:2.4.0
    tty: true
    network_mode: host
      - NET_ADMIN
      - NET_RAW
    container_name: openhab
    restart: always
      - /etc/localtime:/etc/localtime:ro
      - /etc/timezone:/etc/timezone:ro
      - /opt/openhab/addons:/openhab/addons
      - /opt/openhab/conf:/openhab/conf
      - /opt/openhab/userdata:/openhab/userdata
      EXTRA_JAVA_OPTS: -Duser.timezone=Europe/Berlin
      CRYPTO_POLICY: unlimited

Now most of my equipment is detected, but still no television. Following this superuser.com topic I can find my television (executed on the host), so the broadcast does not seem to be my problem.

Does anyone here have another idea what to do in this situation?

Found the solution by clicking around in the Paper UI… Setting the IP in the OpenHAB configuration does not work. If you set the actual IP (without subnet) in the WebOS-Binding (in my case, the TV shows up. :heart_eyes:

Hello @darkspirit510,

where/how did you setup the NIC in the WebOS-Binding?
I cannot see any settings for this.


This is no binding specific thing, it’s a general setting of openHAB.

For openHAB 2.x: see above
For openHAB 3.x: Login, Settings, System settings, Network.

But no warranty about this, i stopped using the WebOS-Binding.


Thanks a lot for the fast reply. !