[SOLVED] Logitech Harmony Hub Binding - 4.15.206 firmware broke local API connection

Thank you so much for posting! Worked perfectly!

Agreed, upgrading is up to you. I plan on moving to the websocket connection, but I don’t have an ETA on when it will be done. I started last night and so far so good, but I will be completely re-writing our connection library. The good news is that it will be 90% less code, most of the logic was in managing XMPP messaging, much much easier using websockets, so I’m kinda excited to go down that route. Let’s hope logitech doesn’t stop this method as well.


I also found this:


couldn’t find if somebody posted this update (50m ago)

Thanks for your work! And I think this is the “easiest” way to ensure that Harmony works with OH. This developer fw is temporary I think and as others reported, Logitech will shut down this method in the near future…

Thank you for clarifying this. :slight_smile:

Thank you for this.

Just installed the newly released developer FW, and OpenHAB is once more in control of my Harmony Hub! :slight_smile:
Kudos to Logitech for actually listening to their users. :+1:

Here’s a link to the vulnerabilities that were found by Tenable and fixed by Logitech:

1 Like


Hey there =)

First of all: thanks Logitech! u f’ed it up really good.

Every time I try to downgrade my harmony hub I get this:

I get this when I try downgrade on the “Harmony Home Control” Site and on the “Firmware to enable XMPP” Site. I tried this on my desktop and laptop with fresh installs of the Harmony software.

Of course I tried to unplug and retry the process.

Anyone got an idea?

Logitech has now anyway announced they will make an update for giving local access again. Until then, they opened up for a workaround. See here (in German, but somewhere else it’s perhaps in English too?)

## Logitech lenkt ein: Nutzer erhalten wieder lokalen Zugriff auf Harmony Hub

You try to upgrade from 4.15.206 to developer Firmware 4.15.210? It’s telling you, it’s a downgrade?
I’m still on 4.15.201. And I didn’t upgrade yet.

Maybe you first have to downgrade to a previous version --> 4.15.193 and then upgrade to 4.15.210?

What are the experiences of others, who did an upgrade?

For me it was pretty straight forward. I first updated the MyHarmony Desktop client on Windows 10 and then followed the instructions. Both of my hubs were automatically updated to 206 when I was on holiday. They are now using the developer firmware. No issues so far (using openHAB 1.x).

1 Like

Have you tried another USB cable?

Really? Or is it ironic and I missed the point?

I personally feel, they made it the wrong way. Just the pressure the open source community put on the company, the bad headlines in the tech magazines etc. have lead to change it back and re-enable the api.

Initially they seemed not having the intention giving us the local access to our paid devices back.

We have to be grateful to the the open source community and home automation enthusiasts which created that pressure.

Thank you, community!


just installed the dev firmware, worked fine, thanks to all your efforts.
greetings Andy

Logitech just released a firmware 4.15.210 that re-enables the API. They say they don’t recommend it but you have the option to get back to business. (Alt + F9 -> scroll down the page to the last option “Firmware to enable XMP”).
It works now!

what a piece of …

I was travelling for one week and got back and found my hubs not working anymore. OK, found the temp solution to install dev firmware, good. But then I wasn’t able to install harmony desktop software because faulty installer and wrong file permissions to AppFiles.zip

This fixed it for me (scroll to the bottom, last posting)



Thanks, seems to work :slight_smile: