[SOLVED] Lost most of my Things, can't add them back

Tags: #<Tag:0x00007fc8ff234d60>
  • Platform information:
    • OS: what OS is used and which version Windows 7
    • openHAB version:2.2

I was attempting to install the RC of AmazonEchoControl when, and I don’t have much reason to think it’s at fault, I lost the majority of my Things. I was left with 5. Why 5? Why this 5? Not sure, they are a mixture of zwave, wifi devices.

The remaining 13 were gone, but I also have 13 items showing up in the inbox. There they are.
Problem is, when I try to add them back, Error 404 Not Found. I’ve deleted them from the inbox and rebooted. They come back to the inbox and I can’t add them back. I removed the AmazonEchoControl of course.

The openhap.log and events.log don’t show anything when I try to add them back. Any ideas on how I can get my things back? I’m not sure what other logs I should be looking in for more detail on the 404 error.

Are your things defined in a text file too?
Have you tried to clear the cache?

I’ve not cleared the cache before…doing that brought the things back. Looks like I just need to clear out the duplicates from the inbox now. That is exactly what I needed.
Thank you for your help!

Cool, please mark the thread as solved, Thanks