[SOLVED] Loxone binding authentication issue

update : I was running openhab on QNAP and it was version 2.2, the binding for Loxone was also 2.2. Updated openhab to 2.4 (QNAPClub) and got Loxone 2.4 binding, which is working

I cannot activate the binding with Loxone.
I tried through the PaperUI, and even through a loxone.things file.
I am 100% sure that the credentials are correct.
I ensured that I have the crypto unlimited setting in my JRE, and I tried different account in Loxone and different authMethod settings.
Running Loxone
First attempt gives UNAUTHORIZED, second attempt a 4003 error (IP blocked)

Some logging :
2019-08-06 20:36:32.271 [DEBUG] [ding.loxone.internal.core.LxWsClient] - [1] sending command: authenticate/3245a257700126c45be0a9179754e180409cffc2

2019-08-06 20:36:32.363 [DEBUG] [inding.loxone.internal.core.LxServer] - [1] Websocket goes OFFLINE, reason UNAUTHORIZED : Websocket credentials unauthorized…
2019-08-06 20:36:32.363 [DEBUG] [ding.loxone.internal.core.LxWsClient] - [1] Closing websocket session, reason : Websocket credentials unauthorized.