[SOLVED] [Lutron2] Broken dependency on OH2.4.0.M6

  • Platform information:
    • Hardware: Intel 64bit, 8 GB ram, 128 GB storage
    • OS: Ubuntu 18.04
    • Java Runtime Environment: Oracle JDK 8 191
    • openHAB version: 2.4 M6
  • Issue of the topic:
    I had a stable and running 2.3 setup.
    There were some new features and device support for Lutron and Xiaomi that I wanted and were included in the 2.4 Milestones

I tried updating my PPA and running apt update/upgrade

Open would fail to start with messages about not being able to find the Lutron bundle.

reverting to 2.3 would correct that and OH would start and run.

I then removed OH with apt remove and deleted all files listed in

I would then install M6 with apt install

OH fails to start

Trying with openhab-cli

smitopher@myth-server:~$ sudo openhab-cli start

A systemd service configuration exists...
Use 'sudo /bin/systemctl start openhab2.service' to start an openHAB service
Launching an instance in this terminal..
Launching the openHAB runtime...

                          __  _____    ____      
  ____  ____  ___  ____  / / / /   |  / __ )     
 / __ \/ __ \/ _ \/ __ \/ /_/ / /| | / __  | 
/ /_/ / /_/ /  __/ / / / __  / ___ |/ /_/ /      
\____/ .___/\___/_/ /_/_/ /_/_/  |_/_____/     
    /_/                        2.4.0.M6
                               Milestone Build   

Hit '<tab>' for a list of available commands
and '[cmd] --help' for help on a specific command.
Hit '<ctrl-d>' or type 'system:shutdown' or 'logout' to shutdown openHAB.

Error in initialization script: /var/lib/openhab2/etc/shell.init.script: /var/lib/openhab2/etc/shell.init.script

Googling did not give anything helpful
What am I missing?

Well, some additional data points

I removed all Lutron items and things.
I uninstalled the Lutron binding

I stopped OH

I updated the PPA to testing

I upgraded with

sudo apt install openhab2 --reinstall

I can start OH with

sudo openhab-cli start

From the Paper UI, I attempt to install the Lutron binding.

It fails

==> /var/log/openhab2/openhab.log <==
2018-11-25 20:46:40.245 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-lutron': Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-binding-lutron; type=karaf.feature; version="[2.4.0.M6,2.4.0.M6]"; filter:="(&(osgi.identity=openhab-binding-lutron)(type=karaf.feature)(version>=2.4.0.M6)(version<=2.4.0.M6))" [caused by: Unable to resolve openhab-binding-lutron/2.4.0.M6: missing requirement [openhab-binding-lutron/2.4.0.M6] osgi.identity; osgi.identity=org.openhab.binding.lutron; type=osgi.bundle; version="[2.4.0.M6,2.4.0.M6]"; resolution:=mandatory [caused by: Unable to resolve org.openhab.binding.lutron/2.4.0.M6: missing requirement [org.openhab.binding.lutron/2.4.0.M6] osgi.wiring.package; filter:="(osgi.wiring.package=gnu.io)"]]

So I guess the Lutron Binding is borked at the moment. This is a Milestone and not a Release so I guess I should not be all that surprised

It seems that there is a broken dependency on the gnu.io (serial transport) that is not automatically resolved during the installation of the lutron binding.

try to install the serial transport bundle from the OH2 console:

feature:install openhab-transport-serial

If this works, report back so we can open an issue against the lutron binding

1 Like

yup, I can reproduce this one

Solution is to install the serial bundle

Opening github issue now

here you go:

1 Like

Thank you

I installed the bundle from the console as suggested, then installed the binding with the paper UI and that was successful

1 Like

PR was made by the maintainers team and approved so the fix will be included soon.
thanx for reporting this!