[SOLVED] Mail binding issue - again

I’m stuck again with this error with the new mail binding:

'sendMail' is not a member of 'org.eclipse.smarthome.core.thing.binding.ThingActions'; line 73, column 25, length 87

Previously I had this error due to also having the old mail Action which is removed. I believe the problem restarted with the change from 2.5.0 to 2.5.1.

Current version of the mail binding:

openhab> bundle:list | grep -i mail
213 x Active x  80 x 1.6.2                   x JavaMail API
220 x Active x  80 x 2.5.1                   x openHAB Add-ons :: Bundles :: Mail Binding


 val mailActions = getActions("mail","mail:smtp:mysmtpserver")
 mailActions.sendMail("myemail@gmail.com","PL Locks", "Door locked")

@J-N-K any ideas?

Had the same issues when changed to 2.5.1.
I had to restart openHAB a few times and then it suddenly started working again…

Hmm. Rebooted and now it is working. This is a nasty problem because you don’t know to check for the issue, and it appears that it kills any rule that it is running in. My remote heater didn’t start up because of this. Hopefully it can be solved by the time 3.0 comes out…

Yes, in my opinion the biggest issue with openHAB2 right now is that the startup sequence is not (correctly) handled.
These cause a lots of warnings and problems and it is hard to figure out that it is a real issue or just something went wrong during startup. The best advice right now is to restart openHAB after an update/cache clean a few (2-3) times. If the issue is still there, then it might be a real issue…

1 Like