[SOLVED] Manually Update ZWave Binding?


My search-foo is not good.
How do I manually update the Zwave binding and how do I download the file?


The readme for the script also has steps for doing it manually, in case you don’t want to use the script. In recent snapshot builds, manual installs have not been working for me, so YMMV.

1 Like

Should I be able to install the latest on 2.5M1?

I haven’t tried, but I think I’ve seen people reporting that it is working for them.

1 Like

You find the latest snapshot here


Download and put it in the addons folder.

You would have to de-install the binding in Paper UI first. But no worries devices are still there if the controller is not reset or the devices not removed. They will be in the inbox again

1 Like

If that is all you do, you’ll get errors for gnu.io unless something has already installed the serial transport feature. You’ll also get errors about xstream, so you’ll need to find and install that jar too. The uninstall of any existing zwave bindings (manually installed too) and the install of the new binding and dependencies are all taken care of in this script and documented (with download links) in the readme, if you want to do it yourself.

1 Like

@5iver how do you find binding dependencies?
I was thinking of using the darksky binding that is only in snapshots. Apparently it has unmet dependencies in 2.5M1.
Thanks again for your help. I got Zwave updated successfully.

Install it and the errors will guide you to what is missing. However, it may also use something in core that was not implemented in 2.5M1.

It looks to need gson, which you can find here… https://mvnrepository.com/artifact/com.google.code.gson/gson.

1 Like

Thanks. That is exactly what I was missing.
My API Account is online so it should be working now.

Cool! Could you please let the person in the thread I linked know which version worked for you? I didn’t see a response to their post.

I just edited my last post in the script thread to say I was using version 1.2.1.
Is that what you mean?

I meant the version of gson for the person in the darksky thread (linked 4 posts up).

OK, I’ll respond to myself & say I used gson version 2.8.5 :smiley::rofl:

The information may be helpful to other though. Thanks for the attention to detail.

You must not see the link I’m referring to. This person was asking how to use darksky with 2.5M1 and you could help them with that information…

In my case OpenHab2 2.4.0 on RP4 was missing the xstream package. Refer to this other post

The script I mentioned handles that new dependency.