[SOLVED] Mios binding not working on 2.3.0

Tags: #<Tag:0x00007faf81ed9b98>

Hi everyone, so I have been at this for a week now and have tried running on Windows and Linux devices and still can’t seem to get this to work. So I activated mios binding then went and configured the mios.cfg and added the house.items file that I had exported using the item generator. Now I am stuck and have searched everywhere on here and could not find anything to help. I don’t know what else I am missing and finally decided to see if I could get some help. Thank you in advance.

Josh

Ok, we need more info there.
Post your mios.cfg file
Post your items

In the mios.cfg file, the only important line to uncomment and set properly is this one:

house.host=192.168.0.42

Just set the IP of your Vera box.

And of course, the binding is not broken but works perfectly in 2.3 and 2.4 snqpashots.
So it is only your setup that is wrong.

Thank you for your replies.

Here is a pdf print of my mios.cfg file. I uncommented the line and set it to my devices ip (i have set the vera device to a static ip so it doesn’t change.
mios config file.pdf (29.7 KB)

Here is my items file. I didn’t change anything here in my file as the documentation on this part is pretty vague.
house items file.pdf (76.0 KB)

Sorry these are pdfs the system wouldn’t let me upload my actual files. Thanks again for the help.

Josh

Alright, I was able to figure it out. After reading everything and confirming and reconfirming everything was right I decided to try and find the logs as from what I have read this can help sort things out. Sure enough, there was a line saying that one of the lines did not contain a , and the file was then ignored. I removed the whole line as it was an item I didn’t need and it came right up. Thanks for your patience with me and I’m happy to say it is now working correctly.