[solved?] Most recent docker [openhab:amd64-online] fails to start properly

I just downloaded the latest docker image and started with some fresh config folders because my old OH2 docker image was getting old and some configuration was not correct.

However everything starts fine but I cannot choose any UI, did I do something wrong or is the latest snapshot a little of?

Docker compose file:

openhab:
  image: 'openhab/openhab:amd64-online'
  ports:
    - "8080:8080"
    - "8443:8443"
    - "5555:5555"
  net: "host"
  volumes:
    - '/etc/localtime:/etc/localtime:ro'
    - '/etc/timezone:/etc/timezone:ro'
    - '/meru/docker-configs/openhab/userdata:/openhab/userdata'
    - '/meru/docker-configs/openhab/conf:/openhab/conf'
    - '/meru/docker-configs/openhab/addons:/openhab/addons'
  command: "server"

Screenshot:

Log:

2016-12-07 11:23:44.227 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at /start

see also issue https://github.com/openhab/openhab-docker/issues/39

The offline distribution gives a better result, I can select a UI if I use the offline distribution. Does this ring a bell for anyone?

Same problem. Please Help

I used the offline distribution, and after that I could switch back to the online while maintaining the UI.

One interesting thing is the BOM (byte-order-mark) in the index.html

OK thanks.
Tonight I will see if there will be a new fixed build to correct the issue otherwise I will unistall the online and install the offline

Maybe it’s just a performance issue.

I removed all my configuration and tried it again with the online one. After 10 minutes I checked and it was all there, maybe it breaks if you cancel the downloaded by stopping the docker container (because you forgot the -d parameter like I did a few times).

I am a noob but I suppose it was a build problem since if I try to upgrade in ubuntu with apt-get upgrade I always find a openhab upgrade even if I just donwloaded and installed.
What do you mean to remove your configuration?
Do you mean all the items, service, sitemap, etc. etc. directories or what else?
I am not at home and I can’t made any test
Regards
Lorenzo

For me its purely a problem with the OH2 docker, since I was using docker only for test purposes I did indeed remove all the items.

Are you also running openHAB2 as a docker container?

Sorry I am a noob.
I use Openhab2 and classic + habpanel + paper ui
I use 2.0 binding 1.0 official bindings and a coupple of manually added
binding.
I really don’t know what s a docker.
Can you explain.
Thanks forma tour patient

It does take quite some time for OH to download and install all the default stuff like PaperUI and such. It happens much faster (depending on your download speeds) using the offline distro which may explain the different behavior you say between the two.

You can also jump start the whole process by putting the UIs in addons.cfg.

In any case, when running a new install with a new userdata folder, make sure to watch the longs and don’t expect everything to be there until you see the logs stop.

If you are not running in Docker you are not necessarily experiencing the same problem. I recommend posting a new topic.

Please describe your setup (OS, how you installed), any steps you have taken, amount of time you wait and any configurations you have made or not made.

The main problem was that I saw nothing happening in the log, so at the default log level there seems nothing to be seen while it is blocked / downloading

I closed the issue which I opened because I don’t think it is caused by the openhab-docker project.

@rlkoshak do you think I should open an issue at one of openhab2 projects? And if yes at which one?

I think it would be openhab-core.

I just come back home - reinstalle the upgrade and quickly the page is popolating with the UI.

I do nothing but wait :wink:

The only drawback is that I lost my items … but I wait maybe they will appeare again

No, they won’t. If they are not showing up right away they are gone. You will need to recreate them. If you are upgrading from an older version of OH (over a week ago or older) to the latest snapshots there is a breaking change which replaced the database where your Items used to be stored.

Or if you deleted userdata then you wiped out your Items yourself.

Sorry I made a mistake. I miss the things not the items.
I do not cancel my user data infact I still have all sitemaps and items running including the HABpanel templates and all html and icons.
Even the bindings seem correctly installed.
It seems the only missing It are the things (by the way easly automatic added) and the rest UI seems not completly loaded but I will wait for a while