[SOLVED] Moving from OH3 snapshot to OH3 M3, some Bindings in marketplace disappear

Hi all,

I have a very crazy situation coming from my latest migration from 3.3.0 snapshot to M3 (now M5).

Consider almost all Bindings have been installed via PaperUI, OpenHAB Distribution


  • Unifi Binding (Beta version) has been installed via PaperUI, Community Marketplace

  • Amazon Echo Control Binding (SmartHome version) has been installed via PaperUI, marketplace section called “Other Add-Ons”


  • Unifi Binding (Beta) disappeared from the Community Marketplace, workaround: installed manually in the addons folder

  • Amazon Echo Control Binding (SmartHome version): disappeared from the “Other Add-Ons” section. The binding is still installed, I can see it in /var/lib/openhab/martketplace. But I don’t have any other option to install/remove

I’ve tried rebooting the system, cleaning up the cache, but I didn’t find a solution. In the starting log I see:

2022-05-08 10:57:54.714 [INFO ] [community.CommunityKarafAddonHandler] - Reinstalling missing marketplace KAR: json:org-smarthome-binding-amazonechocontrol
2022-05-08 10:57:56.176 [INFO ] [rketplace.MarketplaceBundleInstaller] - Reinstalling missing marketplace bundle: marketplace:131156

Any clue how can I troubleshoot and fix?


Not that it helps you, but I just upgraded from M3 to M5 and the Unifi beta binding is still installed.

I’ve only ever installed this binding through the Marketplace, never a manual jar, if that makes any difference…

this is what I see now :frowning:

but it was like yours, before the migration.


3.3.0 M6 solved that. Now I see everything :slight_smile: