[solved] MQTT binding - not seeing "connect to broker" message on windows

I’m trying to setup a new OpneHAB application, currently running on a Windows 7 box. In the past, when I have a MQTT broker specified in the openhab.cfg file, I’ll see a message when I run the .bat file…something that saids “connection to mqtt broker successful”.

I saw it once with this new installation of OpenHAB. But the IP address was incorrect, so I edited the cfg file and corrected it. Then I restarted the .bat.

I’m not seeing the MQTT broker message in the start-up this time around. It’s not even trying to connect to a broker, it seems. I’ve made sure that:

  1. MQTT broker is specified in my openhab.cfg file. In this case, it’s name “mymosquitto”


  1. MQTT binding is in the addons folder.


I’m not sure what I did to screw it up? I’ve started fresh openhab applications a few times, and I thought these were the only two things I need to do to get it to connect to MQTT broker.

Not sure what happened. I copied the openhab.cfg file from the downloaded zip and re-edited the mqtt broker line with the exact same thing, and now it works.