[SOLVED] MQTT issue with Paradox Alarm

Hi all

I’m not getting any MQTT messages

It seems all ok from log:

reading config
finished setting log
INFO:root:logging complete
INFO:root:Rolling old log over
INFO:root:config.ini file read successfully: 0
INFO:root:State01:Attempting connection to MQTT Broker:
INFO:root:State01:MQTT client subscribed to control messages on topic: Paradox/C/#
INFO:root:State02:Connecting to IP Module
INFO:root:Connecting to
INFO:root:Logging into alarm system...
INFO:root:Login to alarm panel successful
INFO:root:Connected to MQTT broker with result code 0
INFO:root:Command 0x5F : Start communication
INFO:root:Command 0x00 : Initialize communication
INFO:root:State02: Logged into IP modeule successfully
INFO:root:State03: Preading labels
INFO:root:State03:Updating all labels from alarm
INFO:root:updateAllLabels: Topic being published Paradox/Labels/WirelessKeypads1:;2:;3:;4:;5:;6:;7:;8:
INFO:root:updateAllLabels: Topic being published Paradox/Labels/WirelessSirens1:;2:;3:;4:
INFO:root:updateAllLabels: Topic being published Paradox/Labels/SiteNames1:
INFO:root:updateAllLabels: Topic being published Paradox/Labels/Partitions1:;2:
INFO:root:updateAllLabels: Topic being published Paradox/Labels/WirelessRepeaters1:;2:
INFO:root:updateAllLabels: Topic being published Paradox/Labels/Outputs1:;2:;3:;4:;5:;6:;7:;8:;9:;10:;11:;12:;13:;14:;15:;16:

And this is my config

Pincode: pin                           ;PC Password (from Winload/Babyware)
Password: password
IP_Software_Port: 10000

[MQTT Broker]
Port: 1883
Mqtt_Username = user                      ;MQTT username, without qoutes
Mqtt_Password = password                      ;MQTT password, without qoutes

Alarm_Model = ParadoxMG5050             ;Currently not used
Alarm_Registry_Map = ParadoxMG5050      ;This is used to map to the correct dictionary class within the ParadoxMap.py package. The word$
Alarm_Event_Map = ParadoxMG5050         ;This is used to map to the correct dictionary class within the ParadoxMap.py package. The word$
Zone_Amount = 32

[MQTT Topics]
Topic_Publish_Events = Paradox/Events   ;The main topic used to publish all events
Events_Payload_Numeric = 0              ;1=Events are reported using numeric value [not replaced by the dictionary]. 0=Events are trans$
Topic_Subscribe_Control=Paradox/C/      ;All controls are given through this high-level topic
Startup_Publish_All_Info = True         ;Upon startup publish all labels from the alarm (configured names of things), only application $
Topic_Publish_Labels = Paradox/Labels   ;The topic used to publish labels
Topic_Publish_AppState = Paradox/State  ;Publishes the scripts internal states, useful to check if connection is alive
Topic_Publish_ZoneState = Paradox/Zone  ;Publishes the zone status' with the zone name as the next topic group (1 for open, 0 for close$
Topic_Publish_ArmState = Paradox/Partition  ; Publishes the partition status 1 for armed, 0 for disarmed.
Topic_Publish_Heartbeat = Paradox/Heartbeat ; Publishes a periodic message, and it a last will and teastament of the mqtt connection
Topic_Publish_Status    = Paradox/Status    ; publishes specific parts of the 6 zone status messages (0 - 5)
Publish_Status_Factor   = 10             ; A keepalive sequence is 6 seconds, this factory will publish the Status/0 message every fact$
Publish_Static_Topic = 1                ;Publish events emulated as topics, E.g. Paradox/Events/0/20
Publish_Zones_OpenClosed = 1    ; Publish OPEN and CLOSED for zones if 1, or ON and OFF is 0 (openhab contact items)

Debug_Mode = 0                          ;0=Minimal, 1=Basic, 2=Verbose
Startup_Update_All_Labels = True        ;Upon startup collect all labels from the alarm (configured names of things). Required for conf$
Log_File = /opt/paradoxip/paradoxip.log ; can also use Log_File = stream://sys.stderr for stderr stream (for docker)
Auto_Logoff = True                              ;When detecting another 3rd party connection to the IP module, logoff for the Logoff_De$
Logoff_Delay = 120   ;Delay before reconnection after a 3rd party connection attempt

What else can I check?

I use the broker also for other stuff, and I get the messages.

I’ve read this thread but haven’t found a solution.


put it in verbose (=2) just to see if it says anything more…

Your logs look clean and your config looks correct also.

If your broker is on localhost, try setting in config.ini:

[MQTT Broker]
Port: 1883

Do you have authentication enabled on your MQTT Broker?

Also, I have:

Publish_Static_Topic = 0

but this shouldn’t be the problem…

Thanks @Dim

My MQTT broker is on another server

I have put the Publish_Static_Topic = 0 and Debug_Mode = 2 and now I get a lot of DEBUG:root:

should I post all of them ?

I’m using MQTTBox as client and I have subscribed to # to get all messages coming from any one.

no, because they contain your pincode :slight_smile:

just see if you identify any MQTT related problems (or IP150 login problems) in the debug.

I don’t know what to suggest other than to double verify your MQTT & IP150 logins (although the log reports that login was successful to both the Broker as well as the IP module…)

can you connect from the host running the python script to the broker (e.g. using mosquitto_sub ?)

That was the issue.

I’ve tried both _sub and _pub but none seems to work.

No error messages, but no message published and nothing subscribed.

My MQTT broker is the default one in Home Assistant :roll_eyes:

I’ve changed to another one found in the addon and now it’s working…

Really strange.

Now I change the title in solved


1 Like

Right, so the issue was the mqtt server? Do you run the internal one? I have a mqtt server seperate from my home asistant and openHAB instances. Since I do use both and also use mqttwarn for notifications. So it didn’t make sense for my mqtt server to be dependant on one software.

Also makes it easier for debugging as you can grab the mosquito log file.

Glad you got it sorted. I was wondering if it was the mqtt user and password. Though I remember someone, maybe @Dim

1 Like


oops… yeah, I remember that I had fooked up my credentials when I was setting up the bridge and you helped :slight_smile:

No, it wasn’t user/password that were wrong.

Some issue with that MQTT broker addon…


I am also using an MG5050 panel. I can see that the connection between my mqtt broker and my raspberry pi running openhab is ok but no communication between openhab and my MG5050 seems to work.

Is it possible to share some code?