[Solved] MQTT issue

Currently I am on 1.8.3 with the 1.9 action and binding for MQTT (tried 1.8.3 previously with the same issue)

I have mosquitto runnning and I get the sensor data just fine. When I try it with mosquitto_sub I get:

test/temperature/28-0000086a746c 21.187

I have configured openahb.conf

And an item:
Number mqttTest “Temperatur: [%.1f °C]” {mqtt="<[mosquitto:test/temperature/28-0000086a746c:state:default]"}

Now here is the issue: when I use the above item configuration I get most of the times nothing. Sometimes I get the Error:
2017-01-19 23:29:00.697 [WARN ] [.c.i.events.EventPublisherImpl] - given new state is NULL, couldn’t post update for ‘mqttTest’

If I change the item configuration:
Number mqttTest “Temperatur: [%.1f °C]” {mqtt="<[mosquitto:test/temperature/28-0000086a746c:state:default:.]"}

2017-01-19 23:47:49.974 [DEBUG] [.o.b.m.i.MqttMessageSubscriber] - Skipped message ‘21.187’ because Message Filter ‘.’ does not apply.

So I do get the values, Openhab just somehow is not able to parse them.
I write the values via the python mqtt client and I have tried both: sending a float and a string. Same behavior.

It appears that using a string instead of a float did make the difference. Now the filter needs to be set to .* (did not work without filter event though it is supposed to be optional) and it works

Is there a space before the temperature value?
The first number item you’ve quoted looks correct.

I have this problem too. How to solve this problem?

Well I got in my items configuration sth like this for a number value (temperature)

And this works just fine. ( I am on OH 2.2 in the meantime.

Number mqttTest0 "TestItem: [%.1f °C]" {mqtt="<[mosquitto:test/temperature/28-0000086a2210:state:default:.*]"}