[SOLVED] MQTT Location fails to display properly

Hello, again.

I’ve got everything set up so far, and I’m now setting up everything MQTT. Which works so far, with one exception. I’m trying to get my phones location over MQTT, the CloudMQTT Broker is setup and works so far. However, my location doesn’t show in Paper UI, the only thing I get is “- °N, - °E, - m”

The topics do work, as I’ve tested via MQTT fx and the output would be:


openHAB also receives this data but fails to display it properly. So what am I missing here?

Could be a ton of things. We need more information.

What version of OH?
What version of the MQTT binding?
How did you install the binding?
Did you do anything else to make it work? I think you may need to add CloudMQTT’s certificate to the trust store of Java as documented in MQTT Binding and SSL.
Tested how?
Show your Thing/Item configs.

Oh, sorry, I completely forgot that

I’m using OH 2.5.0 M1 with the corresponding MQTT 2.5.0 M1 version, installed from the Addons Section.

No I didn’t use anything else to make it work, and have SSL disabled for now, as I’ve read theres currently issues regarding that.

Tested by looking into the Log of CloudMQTT and seeing the openHAB installation as a subscriber, and now after messing with it some more getting an actual error message.

Command '{"_type":"location","acc":15,"alt":146,"batt":31,"conn":"w","lat":49.xxx,"lon":8.xxx,"t":"p","tid":"pn","tst":1553203947,"vac":2,"vel":0}' not supported by type 'LocationValue': null

Edit: Solved it, i used the wrong Item type.