[SOLVED] Mqtt stopped working after upgrade to 2.4 (release)

I’ve just upgraded from RC1 to the release version, and my mqtt has stopped working as the v1 version of the binding is no longer available, and after installing the new binding the new version isn’t working for me.

I’m guessing it’s because of the binding upgrade. Can anyone give me any pointers please?

Dimmer 			MKBlindsControl1 	"Office Blinds [%s]" 	<rollershutter>		(gBlinds, FF_Office)	[ "Lighting" ]	{mqtt=">[broker:MK-SmartHouse/utilities/MK-BlindsControl1:command:*:default],<[broker:MK-SmartHouse/utilities/MK-BlindsControl1/state:state:default]", autoupdate="false"}
1 Like

You need to enable legacy v1 bindings in PaperUI in Configuration -> System. Then the old binding should be available (to install).

1 Like

thanks Hilbrand, that’s got me working again.

1 Like


Perhaps see discussion here: MQTT binding version 2.4 (Pre-release !)