[SOLVED] My default ICONset is not working anymore

Tags: #<Tag:0x00007f616eae4670> #<Tag:0x00007f616eae45a8>

Seems I have lost my default ICON set and icons like temperature and humidity will give an empty result in my basicUI. To be honest my sitemap does not show any icons apart from icons defined in the folder “/etc/openhab2/icons/classic” starting with “self…”. Think I found the iconset on internet (https://github.com/eclipse/smarthome) but unsure how to fix this.

How can I get the default icons available again? Any ideas?

I also notice that inside HABpanel there is a similar problem which was more obvious because the complete icon set “Eclipse SmartHome classic” is missing from the icon selection:

Platform = Raspberry Pi 2 Model B Rev 1.1 (Kernel Linux 4.14.98-v7+)
OpenHAB 2.5.0~S1507-1 (Build #1507) (through Openhabian)

Missed this topic:


So went into the concole with:

ssh -p 8101 openhab@localhost

Folowed the solution of this Topic:

feature:install openhab-iconset-classic

To be honest skipped “FEATURE” in my first run and was buffled with:

Error executing command: Error installing bundles:
Unable to install bundle openhab-iconset-classic: org.osgi.framework.BundleException: Error reading bundle content.

But second try with “FEATURE” included solved the problem. :grinning:

1 Like