[SOLVED] My sitemap has disappeared

Good afternoon,

I had a sitemap working on openhab2 on Raspbian on Raspberry Pi 3 B+ and I added to my persistence rrd4j an item and then added the graph to the sitemap and when I enter to , the message shown is:


Available sitemaps

It seems like you have not defined any sitemaps yet. To build one, please check the documentation for guidance.

My sitemap is on openHAB2-conf\sitemaps and it worked until now.
This is my sitemap local.sitemap

    sitemap local label="piDOMOhome" {
        Frame label="Casa domòtica" {
            Switch item=MotionTrig label="Activació alarma"
    		Switch item=Alarm label="Notificacions"
    		Default item=Door label="Porta"

            Default item=Motion label="Moviment"
    		Switch item=Servo label="Motor"
    		Switch item=Light label="Llum"
            Default item=Temperature label="Temperatura"
            Default item=Humidity label="Humitat"
    		Default item=Luminosity label="Lluminositat"
    		Default item=Incendi label="Incendi"
    		Default item=Aigua label="Sensor d'inundació"
    	    Frame label="Gràfic temperatura" {
            Chart item=Temperature label="test" period=W refresh=1000

        	    Frame label="Gràfic humitat" {
            Chart item=,Humidity label="test" period=W refresh=1000



I would be greatful if someone could help me.

I have rebooted my Raspberry Pi 3 B+ and the problem’s the same.

Thanks a lot,

Last line, remove the coma before Humidity

Thank you very much!!! :slight_smile:


Be sure to look in the logs when ever something like this happens. I’m certain there was an error message saying it can’t parse your .sitemap file because of the comma.

Thanks a lot, will do.


Please tick the post that provided you with the sotution, thanks

OK, perfect.

Thanks a lot,