[SOLVED]Myopenhab is offline. Openhabian on Raspberry Pi


I’ve just installed openhabian on my Raspberry Pi. I added some items based on HTTP binding. Then I wanted to connect it to myopenhab.org. I entered a UUID and Secret, and I verified my email, but on the site it stills shows it’s offline. In openhab.log I found this:

2019-07-31 09:07:33.584 [INFO ] [io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection
2019-07-31 09:07:34.437 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket .IO error: not authorized
2019-07-31 09:08:02.079 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket .IO error: {}
io.socket.engineio.client.EngineIOException: xhr post error
at io.socket.engineio.client.Transport.onError(Transport.java:71) [214:org.openhab.io.openhabcloud:2.4.0]
at io.socket.engineio.client.transports.PollingXHR.access$000(PollingXHR.java:19) [214:org.openhab.io.openhabcloud:2.4.0]
at io.socket.engineio.client.transports.PollingXHR$4$1.run(PollingXHR.java:88) [214:org.openhab.io.openhabcloud:2.4.0]
at io.socket.thread.EventThread$2.run(EventThread.java:80) [214:org.openhab.io.openhabcloud:2.4.0]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
at java.lang.Thread.run(Thread.java:748) [?:?]
Caused by: java.io.IOException: 400
at io.socket.engineio.client.transports.PollingXHR$Request$1.run(PollingXHR.java:218) ~[?:?]
… 1 more
2019-07-31 09:08:02.106 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = e9aaa6c3-a27e-4701-a2a3-8656e29ddbb3, base URL = http ://localhost:8080)
2019-07-31 09:08:03.213 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket .IO error: not authorized
2019-07-31 09:11:38.679 [INFO ] [io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection
2019-07-31 09:11:40.679 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket .IO error: not authorize
2019-07-31 09:13:22.767 [INFO ] [io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection
2019-07-31 09:13:29.846 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket .IO error: not authorized

Please help me.

Welcome to openHAB.

You need to provide the correct credentials:

I have done it in Paper UI.

Do you see the exposed items on myopenhab.org?
Tried restarting oh and changing the states of the exposed items?

I tried it, but there aren’t any items. Myopenhab.org only says that I’m offline

Again: find your UUID and SECRET in your openHAB folders and provide these to your myopenhab account settings.

@sihui Thanks!!! It worked.

1 Like