[SOLVED] myopenhab/openhabcloud-Persistence not working anymore

Tags: #<Tag:0x00007f617de77b20> #<Tag:0x00007f617de778a0> #<Tag:0x00007f617de77148>

Hi,

after upgrading to stable I made myopenhab running again with the openhabcloud-bundle. I can access my OpenHAB instance quite fine through myopenhab.org, but the persistence does not work anymore (last item update is from 01/27/2017). I already renamed my persistence config to openhabcloud.persist and back to myopenhab.persist.

What am I potentially doing wrong?

Find an extract of my services/addons.cfg here:

# A comma-separated list of persistence services to install (e.g. "rrd4j,jpa")
persistence = mapdb,jdbc-mysql

# A comma-separated list of miscellaneous services to install (e.g. "myopenhab")
misc = myopenhab,hueemulation,openhabcloudatted

and $ cat persistence/myopenhab.persist

Strategies {
    default = everyChange
}

Items {
    * : strategy = everyChange
}

The purpose of persisting values is mainly to have the items available in IFTTT.

Thanks for any advice
Toby

So, I found out that I can manually expose items through the configuration of openhabcloud in the Paper UI. However, I’d still like it better to have the configuration version controlled in a config file.

So, here is the config I was looking for:

https://github.com/openhab/openhab-docs/tree/gh-pages/addons/io/oh2/org.openhab.io.openhabcloud

Exposing whole groups would be quite nice, too. However, this already allows to achieve what I wanted to do.

Did you find out how to enable myopenhab.persist?
I’ve been fighting the same issue during last week. openHAB doesn’t seem to care at all what I write in the myopenhab.persist file which is the place I want this setting stored. I got it to work in PaperUI by checking the item boxes in normal mode. But when I enter stuff in expert mode it doesn’t work. Also tried to add only a myopenhab group (just as described in this post) in expert mode and in persist file with no success.