[SOLVED] NAS not mounted after reboot

  • Platform information:
    Release = Raspbian GNU/Linux 9 (stretch)
    Kernel = Linux 4.19.58-v7+
    Platform = Raspberry Pi 3 Model B Plus Rev 1.3 with SSD connected with cable no Wifi
    openHAB 2.5.0~S1507-1 (Build #1507)

  • Issue of the topic:
    The NAS is not mounted after a reboot, resulting that my backup (Amanda) is not working as expected! Issue can also be found in the still open question of this topic.
    Solution: with a simple “mount -a” this problem can be solved but does anybody have a better solution which is not bound to be forgotten after the next reboot? Expect this problem is caused by booting from a SSD. (PS rootwait in cmdline.txt)

  • Mount section from systemctl:

 -.mount                           loaded active mounted   Root Mount
  boot.mount                       loaded active mounted   /boot
  dev-mqueue.mount                 loaded active mounted   POSIX Message Queue File System
● mnt-nas.mount                    loaded failed failed    /mnt/nas
  run-rpc_pipefs.mount             loaded active mounted   RPC Pipe File System
  run-user-1000.mount              loaded active mounted   /run/user/1000
  srv-openhab2\x2daddons.mount     loaded active mounted   /srv/openhab2-addons
  srv-openhab2\x2dconf.mount       loaded active mounted   /srv/openhab2-conf
  srv-openhab2\x2dlogs.mount       loaded active mounted   /srv/openhab2-logs
  srv-openhab2\x2dsys.mount        loaded active mounted   /srv/openhab2-sys
  srv-openhab2\x2duserdata.mount   loaded active mounted   /srv/openhab2-userdata
● storage-server.mount             loaded failed failed    /storage/server
  sys-kernel-config.mount          loaded active mounted   Configuration File System
  sys-kernel-debug.mount           loaded active mounted   Debug File System

Any advise is appreciated

Have you looked on Raspbian or Debian forums?
This is not a Debian-based OS support forum.

You might want to try _netdev mount option in fstab to delay mounts until network is up.
But if that doesn’t help then as Bruce correctly said, this is the wrong forum for that so please go for a different forum.

1 Like

Thank you both for your quick reactions,
and yes the answer will be out there somewhere on the wide, wider of widest. I tried to find it including:
The last one after @mstormi suggestion to use _netdev (for the proper syntax and to avoid using this forum as helpdesk).

The reason why I asked this question in the first place is that Amanda is an integrated tool (more or less) of Openhab(ian); when an unexpected reboot of the system had occured (due to power failure) it would be a pity that people are unaware of this (possible more generic) manco and their backup set-up is not working anymore. Hence the question asked in this forum.

Syntax used in /etc/fstab

>     /mnt/nas          nfs     nolock,noatime 0 0
> /storage/server   nfs     _netdev,rw,nolock 0 0

Will try to find a better variation which will mount on reboot :slight_smile:
If someone solved this problem before their advise/solution is appreciated.

Perhaps somebody on the Amanda forums could help?
I used Amanda long before I heard about OpenHAB but I have not used Amanda in over 10 years.

Me, too :slight_smile:
Used it 20+ yrs ago to backup our university network and when openHABian was in need of a backup solution and I saw it’s available as an RPi package I decided to revive it.

Come on Bruce and Markus…
It´s obvious he seek help and ask in this forum. Otherweise questions about influxdb and grafana etc. should be avoided as well?
It makes no sense telling him to go elsewhere. He is probably not the only one using openhabian, rpi and Amanda, which in my opinion makes it suitable enough in here.

I really dont get it!

1 Like

Something not mounting on reboot is an OS configuration issue. We do not pretend to be experts in that.
If you do not understand the difference between configuring software and configuring the underlying OS ( in its myriad of “flavors”) then that is not my issue.

You are free to help them., though. I am busy working on some OpenHAB zwave configuration.

I agree, it´s probably not related to openhab. But as I said, there may be openhab users having had the same issue, because it is used together with openhab. If he cant find the needed help here, ofcouse he need to go elsewhere to get it fixed.

No one said anything else…

Noone said it´s your issue either.
As far as I´m concern, I do know the difference thank you.

Which is fine as well.

Look closer and follow the link to https://unix.stackexchange.com/questions/169697/how-does-netdev-mount-option-in-etc-fstab-work/331688#331688

To be honest I did not scroll yet to the bottum of this topic and see this working variation.
The sun started to shine and urged me to go away from my PC :smiley:
So the following syntax are working: /storage/server   nfs  rw,nolock,noauto,x-systemd.automount,x-systemd.device-timeout=30,retry=0,_netdev 0 0     /mnt/nas          nfs4 rw,nolock,noauto,x-systemd.automount,x-systemd.device-timeout=30,retry=0,_netdev 0 0

It slows booting a bit so I will variated to find out better settings for my NAS and the difference between nfs and nfs4 (no indirect question asked)

Thanks for pinpointing to a good solution.

For argument sake I fully agree this was an OS problem and not related to Openhab and/or Amanda.