[SOLVED] Need some help on my tasmota binding

Hello,

I have configured 2 ESP8266 with tasmota to control 2 set of lights. Added them on Configuration -> Things.

The problem is when both are online i can’t control them from the Control Panel. It gives the instruction to power ON but it does nothing. If i power off one ESP, the other one works.

This is the Log file

2019-09-11 09:28:35.551 [ome.event.ItemCommandEvent] - Item 'LampaBanc_Buton' received command ON

2019-09-11 09:28:35.567 [nt.ItemStatePredictedEvent] - LampaBanc_Buton predicted to become ON

2019-09-11 09:28:35.576 [vent.ItemStateChangedEvent] - LampaBanc_Buton changed from OFF to ON

2019-09-11 09:28:37.127 [ome.event.ItemCommandEvent] - Item 'LampaBanc_Buton' received command OFF

2019-09-11 09:28:37.135 [nt.ItemStatePredictedEvent] - LampaBanc_Buton predicted to become OFF

2019-09-11 09:28:37.150 [vent.ItemStateChangedEvent] - LampaBanc_Buton changed from ON to OFF

2019-09-11 09:28:49.629 [ome.event.ItemCommandEvent] - Item 'IshcMihai_BecCamera1' received command ON

2019-09-11 09:28:49.640 [nt.ItemStatePredictedEvent] - IshcMihai_BecCamera1 predicted to become ON

2019-09-11 09:28:49.657 [vent.ItemStateChangedEvent] - IshcMihai_BecCamera1 changed from OFF to ON

2019-09-11 09:28:50.298 [ome.event.ItemCommandEvent] - Item 'IshcMihai_BecCamera1' received command OFF

2019-09-11 09:28:50.312 [nt.ItemStatePredictedEvent] - IshcMihai_BecCamera1 predicted to become OFF

2019-09-11 09:28:50.330 [vent.ItemStateChangedEvent] - IshcMihai_BecCamera1 changed from ON to OFF

2019-09-11 09:28:53.055 [ome.event.ItemCommandEvent] - Item 'IshcMihai_BecCamera2' received command ON

2019-09-11 09:28:53.071 [nt.ItemStatePredictedEvent] - IshcMihai_BecCamera2 predicted to become ON

2019-09-11 09:28:53.085 [vent.ItemStateChangedEvent] - IshcMihai_BecCamera2 changed from OFF to ON

2019-09-11 09:28:55.190 [ome.event.ItemCommandEvent] - Item 'IshcMihai_BecCamera2' received command OFF

2019-09-11 09:28:55.200 [nt.ItemStatePredictedEvent] - IshcMihai_BecCamera2 predicted to become OFF

2019-09-11 09:28:55.209 [vent.ItemStateChangedEvent] - IshcMihai_BecCamera2 changed from ON to OFF

I can control the ESP from the http but not from the openhab when they are both online.

Can someone help?:smiley:

1 Like

Hello Mike,
I’m not sure what exactly is your issue, nevertheless I can show you how is set one of my sonoff switches, : this is Switch channel in sonoff Thing


You need to define state and command topics - if you did not change topic settings after Tasmoata installation than it will look like in my picture - you need to change “bedLight” word to your topic.
Hope it helps.
BR
K

1 Like

Each and every MQTT client needs ist own ID. If you have two Clients with the same ID such Problem could happen.
Using Tasmota you can set the MQTT client ID on the webinterface.

1 Like

ooohh, i didn’t know that…now they work <3

thank youu

Hello, Thanks for the info :D.
The problem was with the client id, it was the same in both devices.

@mike.ish please tell me how did u add iceydev mqtt broker? via paperui? or via .thing file?

via paperui. Do you want help with the configuration?

yes please help me…

Here is a video. i hope it helps. sorry for my english: https://www.loom.com/share/91bb6964d6c6428ca3593e55fd2e4cbd

thanks for video. i have no broker option on my instalation. i dont know why…

Perhaps you need to install the binding first.

you need to install the binding first, in the: Paper UI -> BINDINGS -> MQTT Binding

mqtt binding already installed. but there is no broker option still.

paper ui->addons->binding->mqtt binding already installed but there is no mqtt broker option still.

Well, what do you see when you go to add a Thing?

See his other Thread.