[SOLVED] Neo pd03z using incorrect XML for config

I know the database changed from 2.5M1 to the current snapshots. I am running a snapshot and all my devices are recognized properly. They are not all recognized with 2.5M1.

Hmm something went wrong then between 2.4 and 2.5M1 but now resolved again. @Bruce_Osborne are you running a fresh build of the snapshot from source?

It would be cool to have the function where the pluggin can update live for the database instead of having to generate a new jar file.

I updated my snapshot earlier this week.
I notice the REST API Docs appear broken in my latest snapshot though. for me everything else appears to work fine.
The REST Docs worked in an earlier snapshot.

I think I have a PD03Z at home with different ID string. I need to check this weekend safter I get home.

@Bruce_Osborne Did you manage to check the snapshot at the weekend?

Actually, my system “ate itself” & I forgot.
Just checked nowin Paper UI.
Mfg ID 0259
device id 141
device type 3

So my device ID is 0141 & yours is 108D.

Hmm thank you for the update:


<property name="modelId">PD03Z</property>
  <property name="manufacturerId">0258</property>
  <property name="manufacturerRef">0003:108D</property>
<property name="dbReference">973</property>


<property name="modelId">Motion Sensor</property>
<property name="manufacturerId">0258</property>
<property name="manufacturerRef">0003:0083,0003:008D,0003:1083,0003:2083</property>
<property name="dbReference">401</property>

I can’t see to see your code.

Right I have found the issue.

From paper UI
Mau ID: 0258
manufacturerRef: 0003:0083,0003:008D,0003:1083,0003:108D

The device is crossing over the two config XML’s although the node walk as posed above doesn’t show that.

@chris Is there an easy fix as I am confused why the node walk shows one thing and paperui is different.

I don’t know what the “node walk” is? Can you explain please?

1 Like

My appologies confusion of terms on my side. On openhabian under /srv/openhab2-userdata/zwave the node .xml there for these sensors shows:


Ok, so I guess you mean what I normally call the interrogation?

This gets the data from the device - it will ALWAYS return the value from the device and this is what is placed into the XML that OH creates. This value is then used to correlate the data in the database which brings us back to the same issue I mentioned a few days back -:

Yes thank you too used to SNMP terms.

So I understand more then the way the z-wave plugin works is that it interrogates the “node” and in this case gets:


Then somewhere in the DB lookup and if I follow right is what gets into paperUI I end up with:
manufacturerRef: 0003:0083,0003:008D,0003:1083,0003:108D

Sorry for taking time on this one just trying to understand what is going on under the hood.

Yes - you roughly have it correct.

Thank you appropriate your help.

Looking at the XML themselves:

Looking at the 2.50 branch they look correct. I have tried to compile myself and failed miserably so I haven’t built from the latest to try. So looking at them I not able to see the issue myself.

I’d suggest to ensure you are using the latest binding since from a quick search in the database for 0003:108D (ie your devices ID) it only shows the correct entry (ie the PD03Z) and this also seems to be consistent if I search for this in Github.

I am using the latest compiled release 2.5.0 M1. I would agree with what you are saying about the using the latest binding.

Just check it is using:
2504810 Feb 6 22:24 org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar

This is not the latest compiled binding - it’s the latest milestone release, but as it’s quite old now I’d suggest to use the latest snapshot which will have the database we see in Github.

Dam sorry you right.

I will change now and post back.


Right I have updated restarted OpenHab then the whole OS (As still wasn’t right) with no joys.

2728536 Jul 8 18:12 org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar

Interesting the reinitialize option under advanced is missing now.

This has popped up in the logs since.

019-07-08 18:36:39.931 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.zwave [249]

Unresolved requirement: Import-Package: com.thoughtworks.xstream; version="[1.4.0,2.0.0)"

at org.eclipse.osgi.container.Module.start(Module.java:444) ~[?:?]

at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:383) ~[?:?]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [10:org.apache.felix.fileinstall:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [10:org.apache.felix.fileinstall:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.startAllBundles(DirectoryWatcher.java:1221) [10:org.apache.felix.fileinstall:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:515) [10:org.apache.felix.fileinstall:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [10:org.apache.felix.fileinstall:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [10:org.apache.felix.fileinstall:3.6.4]

I updated my 2.5M1 to the zwave snapshot this past weekend with no issues.
Did you delete the managed zwave binding before placeing the new jar in the addons directory?
You could also try restarting OH.