Only one channel of the ZWave device Neo Coolcam Motion Sensor PD02 reports data

The Neo Coolcam Motion Sensor PD02 has 4 channels

  • Luminance Sensor
  • Temperature Sensor
  • Motion Alarm
  • Battery Level

but only the temperature sensor reports data to my openHAB instance running version 3.1.0 stable. The other channel remain with value ‘NULL’, even though the red led blinks everytime the dvice detects a motion event.

OpenHAB descovers this device as model PD03Z, even though the packaging box says, that it’s a PD02:

There doesn’t exist any file for this ZWave node in the directory “/var/lib/openhab/zwave”, which seems to indicate that there is some issue with the discovery.

The device reports the temperature reliably. This indicates for me, that the ZWave inclusion has worked and the issue isn’t caused by ZWave network problems.

The openHAB forum contains some articles about this device. Several solutions are suggested in these articles, but none of them work for me:

  1. Clear the openHAB cache and reinclude
    As suggested here the device should be excluded from the ZWave network, then the openHAB cache should be cleared (console command “sudo openhab-cli clean-cache”) then the device should be reincluded. This hasn’t changed anything for me.

  2. Some special device configurations are suggested here, but applying exactly these parameters doesn’t help. Strangely the first association group “Lifeline” setting is forgotten after a restart of openHAB:

  3. Deleting the thing in the openHAB admin console and adding it back, while keeping the device alive by permantly klicking its inside button, like suggested here and here doesn’t help either. Also it doesn’t help to klick the inside button three times very fast for wakeup like suggested here.

  4. Performing a factory reset of the device, lihe suggested here and reincluding it doesn’t help.

Can anybody help me out with a configuration for a PD02, that works?

How can I figure out, whether openHAB’s ZWave binding really discovers the correct model type? It looks to me, that it uses this entry in the ZWave device database. In the device database there isn’t a particular entry for the PD02 model. Is another entry needed?

I am aware, that raising the log level of the ZWave binding to TRACE would be helpful to solve this issue. I tried this while adding the device. Due to high system load caused by tracing the device unfortunately wasn’t added at all on my system.

Odds are the device is not fully initialized. Look for the “reinitialize Device” as described in this post and wake MANY times until it appears. Once it appears the XML file will be created and all channels should work.
(Z-Wave) Fibaro FGMS-001 Motion Sensor problems - Add-ons / Bindings - openHAB Community


I am using those units with no issue and have been for sometime. Have you linked all four channels?

That database entry has multiple device entries. sometimes somebody mistakenly adds one. i recently found one of mine like that.
Please post the xml created in the userdata/zwave directory along with a link to tue user manual.

That disagrees with the developer and zwave binding documentation. The documentation says use DEBUG and the developer says TRACE has no additional useful information. The developer even has a log viewer for DEBUG logs.

1 Like