[SOLVED] - New to OH : Popp Stick won't initialize

Hello All,

I have been in home automation for a few years now and used to run Jeedom. I tried Home Assistant but didn’t like it so I want to make a try with OpenHAB.
I’ve looked for my issue here, found some similar topics but couldn’t get the right solution. So I hope to find it asking you. I hope also that my message is at the right place.
I’ve already tried the following : ZigBee coordinator (Popp ZB-stick): Failed to startup ZigBee transport layer

So I reinstall everything, with a clean installation but same hardware that I have for a few years and for this message : RPI 3B+ & ZigBee PoPP coordinator stick (Ember).
Global installation went ok, a few issue but I found all the answers in the community.
I followed the PoPP installation steps as they are documented but for a previous version.
When I set up the configuration (all UI based as I’m new to OH) the interface stays in “Initialising” forever. I have checked the USB port.
The logs don’t show much except :

I won’t copy all the logs as it is verbose in DEBUG but I’ll put the last lines :
2022-10-05 11:48:39.199 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - bundle org.openhab.binding.zigbee:3.3.0 (292)[org.openhab.binding.zigbee.discovery.ZigBeeDiscoveryService(377)] : dm ZigBeeCoordinatorHandler tracking 6 MultipleDynamic added {org.openhab.binding.zigbee.handler.ZigBeeCoordinatorHandler}={service.id=587, service.bundleid=297, service.scope=singleton} (enter)

2022-10-05 11:48:39.203 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - bundle org.openhab.binding.zigbee:3.3.0 (292)[org.openhab.binding.zigbee.discovery.ZigBeeDiscoveryService(377)] : dm ZigBeeCoordinatorHandler tracking 6 MultipleDynamic already active, binding {org.openhab.binding.zigbee.handler.ZigBeeCoordinatorHandler}={service.id=587, service.bundleid=297, service.scope=singleton}

2022-10-05 11:48:39.206 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - bundle org.openhab.binding.zigbee:3.3.0 (292)[org.openhab.binding.zigbee.discovery.ZigBeeDiscoveryService(377)] : invoking bind: addZigBeeCoordinatorHandler: parameters [org.openhab.binding.zigbee.ember.handler.EmberHandler]

2022-10-05 11:48:39.210 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - bundle org.openhab.binding.zigbee:3.3.0 (292)[org.openhab.binding.zigbee.discovery.ZigBeeDiscoveryService(377)] : invoked bind: addZigBeeCoordinatorHandler

2022-10-05 11:48:39.213 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - bundle org.openhab.binding.zigbee:3.3.0 (292)[org.openhab.binding.zigbee.discovery.ZigBeeDiscoveryService(377)] : dm ZigBeeCoordinatorHandler tracking 6 MultipleDynamic added {org.openhab.binding.zigbee.handler.ZigBeeCoordinatorHandler}={service.id=587, service.bundleid=297, service.scope=singleton} (exit)

2022-10-05 11:48:44.289 [WARN ] [core.thing.internal.ThingManagerImpl] - Initializing handler for thing ‘zigbee:coordinator_ember:2b1590557f’ takes more than 5000ms.

and it stays there.

I guess you don’t have enough info to help me with that, so please advice me what you need to help, if someone is ok to help me of course :blush:

Thank you all.

Correct - please can you provide the full log. I appreciate it can be a bit long and verbose, but really without that it’s hard to provide much constructive feedback. You can put the log somewhere (eg Dropbox) and link it from this post.

Hi Chris and thank you so much,

I’ve put the log here : https://drive.google.com/file/d/12cu0YHxQIeuBKUZJYKecXt2IV97q0MZl/view?usp=sharing
I hope it works and you have access.

You’ll see multiple tentative in the logs. I saw a message in the logs saying “missing dependencies” but can’t find anything on Internet on how to add them …

I think you’re using the wrong type of coordinator. The POPP is an Ember coordinator, but it looks like you are using the CC2531 which is not compatible -:

2022-10-05 10:51:22.528 [DEBUG] [.zigbee.cc2531.handler.CC2531Handler] - ZigBee CC2531 Coordinator opening Port:'/dev/ttyUSB0' PAN:8f1d, EPAN:FE887AB743BD5D8E, Channel:11

That was what OH did automatically.
I’ve deleted this one an manually created the Ember one. But you put the finger on something.
I removed it much earlier than 10:51, and it is still in the logs, but not in the UI.
I guess that is the problem.
Any idea on how to remove it properly for the config files ?

1 Like

Strange - I’m not sure why (or more to the point - how) that happened. Certainly the zigbee binding doesn’t do any discovery of coordinators, so I don’t really know what created this.

If you’ve removed it, then is should be gone. Again I don’t really understand what is happening, so it’s hard to say too much (sorry) but I would suggest to restart OH and hopefully it will be gone.

Yes really strange. Thank you for your help.
I’ve looked at the conf folder with the json scripts and there is no trace of the cc2531.
I’m looking for the command to restart openhab without restarting the PI.
if it doesn’t work, I’ll reboot again and keep this tread updated.

sudo systemctl restart openhab

Looking at the logs, and thank you Chris for that, I think it took a lot of time for OH to remove the old Thing with the wrong controller type. And the weird behaviour may be related to a human action as the dongles have been unplugged and replugged and some port changed, so it mixed up with an rfxcom device.
Well well well, lesson learned : one thing at a time :smiley:

Thank you for the support.

1 Like

Glad you’ve made progress. So I guess the big question is - if you add the ember coordinator, is it now working? :slight_smile:

Yes indeed

1 Like