[SOLVED] No access to the RaspberryPi over the ethernet

  • Platform information:
    • Hardware: RaspberryPi 3b+
    • OS: Openhab
    • openHAB version: latest Openhab version

Hello again,

I have a new problem. I can’t get access to the RaspberryPi data or the Openhab data over the network. I don’t mean the console e.g. about Putty, I mean that I am on my Windows computer and from there to the data e.g. the config data for Visual Basic to create items or things etc…


Network2

The meaning of the error is as follows: \RaspberryPI could not be accessed.
Error code 0x80070035
The network path was not found.

The only thing I’ve done so far is:
Install Openhab
update
upgrade
Installing the FireMotD
Change Hostname to RaspberryPI
That’s it.

best regards

Kai

Did you run the openhabian config?

sudo openhabian-config

Hi yes I have. What do you think I forgot or did wrong there?

If you installed openhabian the name of the system was not RaspberryPi after installation. Did you change it?

Yes, i change it to RaspberryPI

Does that say that you can connect via Putty?
If yes, with which settings?

Yes, i can connect via Putty with the IP: adress that i gave my PI and Port 22.

I have two sd cards so i tryed one istallation with standard Name and the same problem.
Putty works as well here with openabianpi port 22(default)

@opus
any further ideas?

I’m sorry, no further ideas from here.

It’s an issue with Windows 10 and compatibility with Samba on Linux. Windows 10 starting with build 1709 disabled “guest” access on the samba/smb protocol in order to tighten up security, so you need to turn it back on. I ran into the same thing and the fix here took care of it.

https://social.technet.microsoft.com/Forums/en-US/eba9a147-c1de-41b1-99aa-9c65efd45d8f/cant-access-smb-share-after-update-to-1709?forum=win10itpronetworking

1 Like

So the fix is to turn the smb1.0 Back on is that right?

This is the post that worked for me. I run Windows 10 Pro so I was able to do the group policy setting via gpedit.msc at the end, if you have Home the registry change in the first link should work.

FYI, I found someone else who found the problem and a fix (for me anyway).
https://tech.nicolonsky.ch/windows-10-1709-cannot-access-smb2-share-guest-access/

MS has an article now to.
https://support.microsoft.com/de-ch/help/4046019/guest-access-smb2-disabled-by-default-in-windows-10-server-2016

essentially 1709 disables unauthenticated access to shares using SMB2. There is a GPO that can easily be flipped to fix the problem if setting up auth isn’t an option. Here is the policy in question.

Computer configuration\administrative templates\network\Lanman Workstation “Enable insecure guest logons”

1 Like

U are the best. It works. THANK U