[SOLVED] No data entries InfluxDB


I’m new to this but I checked everything 10 times now and can’t figure out what’s wrong.
I followed tutorial: InfluxDB+Grafana persistence and graphing

Had no problems whatsoever, but still, there isn’t appearing data in the database. I followed every step, also set the default persistent service to influxdb (Openhab > Paper UI > Configuration > System > Scroll down to persistent and set service).

This is my /etc/openhab2/services/influxdb.cfg:


This is the $OPENHAB_CONF/persistence/influxdb.persist:

Strategies {
everyMinute : “0 * * * * ?”
everyHour : “0 0 * * * ?”
everyDay : “0 0 0 * * ?”

Items {
M3Meter_Delivery, ThermostaatMasterBedroom_Temperature : strategy = everyChange, everyHour

When I connect to my openhab_db and give command show series, it’s empty.

What could be wrong?
Thanks in advance!

out of the top of my head:

-check that you granted all permissions to user openhab on influxdb-openhab_db.
-try restarting openhab service
-are the item names perfectly correct?
-try putting each in one line (i had issues with comma separated list of items’ persistence)
-not sure how it goes with blank spaces, however i have no space between the colon and strategy (:strategy = )

hope it helps :slight_smile:


After troubleshooting the whole morning I found out that it is a permission problem, just like Dario mentioned, when I change the account in: /etc/openhab2/services/influxdb.cfg from the created openhab account to the admin account with credentials, then it’s working.

I already suspected something like that, so I already tried to re-run the command “GRANT ALL ON openhab_db TO openhab” but that didn’t helped at the time, eventually I changed the account what seems to work, apparently the openhab account don’t have the right permissions. For now it works with the work-around, does anyone know how the fix the permissions now?