[Solved] No new versions via apt

Hi all,
after finally learning the change in apt-repository I don’t get any new snapshots versions anymore.

I played around with stable/unstable/testing and currently get

dpkg -l | grep openhab

ii openhab2-online 2.0.0~b5 all openHAB Online Distribution

My apt-configuration is as follows:

cat /etc/apt/sources.list.d/openhab2.list
deb http://dl.bintray.com/openhab/apt-repo2 unstable main

Can you please guide me what to do to get back to snapshot releases via apt?

Thanks in advance,


check this post out:

Applies also to your case (you have OH2Beta5 Online installed). To go to the new snapshots from the unstable repo (or to RC1 from the testing repo) you need to perform: sudo apt-get install openhab2 over the existing, older openhab2-online package version. [Link]
It will upgrade your system without losing any settings/configs (a backup is always a good move in advance of course)

1 Like

Thanks a lot Dim, that nailed it.

Got a new version now. Nice one.

Cheers mate.

P.S.: Can’t find the “Mark as solved”-Button.

1 Like