[SOLVED] Not working SRT-321

Hi all,
I have some problem with the themrostat SRT-321.

The scenario where I want to use it is:

  • OpenHab is running on a RaspberryPi 3B+ with Zwave serial adapter
  • Thermostat is used to control the temperature in an apartment
  • It is possible to change the temperature set point on thermostat (this will send the change to OpenHab)
  • if the thermostat doesn’t have a schedule function to change the temperature setpoint on base of time of day it is possible to change from OpenHab
  • A rule triggered on changes of setpoint or temperature switch on or off

To do all of that I bought a SRT-321 thermostat with a SSR-303 kit. I haven’t any problem with the SSR-303 switch.
With SRT-321 is another story: I can’t change setpoint from OpenHab, I didn’t receive an setpoint update when is changed using the wheel on the thermostat, temperature is received rarely.

What I tried is:
include the SRT-321 using “I” command* (SRT-321 should act as master controller)
exclude it from ZWave network
include the SRT-321 using “L” command* (SRT-321 should act as secondary controller)
*: are the letter in installation mode.

Neither one work, I tried all point above on OpenHab 2.4 and 2.5.0~M3-1.
Any suggestion if I’m doing something wrong? Or how to understand what was wrong?
It is the wrong device for my scenario?

Thanks for any help

I guess you tried 1 or more milestone builds. Did you update OpenHAB or just the minding?
What exact milestone builds did you try? There have only been 3 so far.
That database item was last updated 3 months ago so I recommend one of the last 2 binding versions that I listed.
What version of OpenHAB are you running now?

Check this thread:

thanks for your answer.
I tried the stable 2.4 version and later reinstall with last testing version (reinstall openhabian and later switch to testing using openhab-config) on Sunday. After login in SSH report this version 2.5.0~M3-1 that I suppose is a 2.5.M3…


I will check it ASAP I can work on my openhab at home


just to not leave this hanged up.
As the people say the setpoint works bidirectional, I tried again to included and now it works using the Milleston3 of 2.5.
What I did different is: 1) I paly again with C status (it failed) before include the thermostat to the network and 2) leave the SRT without battery for about 5 seconds between the inclusion and normal operation.

As Sihui mention there is delay when the setpoint is set from OpenHab but for the moment it is acceptable.


1 Like