[SOLVED] Odd behavior after upgrade from 2.3 to 2.4

I’m running OH 2.4 (openhabian) on an RPi3 and since the upgrade, I keep getting these errors in the log every minute or so:

2018-12-26 18:07:13.081 [INFO ] [internal.service.FeaturesServiceImpl] - No deployment change.
2018-12-26 18:07:13.086 [INFO ] [internal.service.FeaturesServiceImpl] - Stopping bundles:
2018-12-26 18:07:13.092 [INFO ] [internal.service.FeaturesServiceImpl] -   swagger-jersey2-jaxrs/1.5.8.v20160511-1038
2018-12-26 18:07:13.111 [INFO ] [internal.service.FeaturesServiceImpl] -   reflections/0.9.10.v20160429-1435
2018-12-26 18:07:13.140 [INFO ] [internal.service.FeaturesServiceImpl] -   io.swagger.jaxrs/1.5.8
2018-12-26 18:07:13.157 [INFO ] [internal.service.FeaturesServiceImpl] -   com.eclipsesource.jaxrs.provider.swagger/
2018-12-26 18:07:13.319 [INFO ] [internal.service.FeaturesServiceImpl] - Refreshing bundles:
2018-12-26 18:07:13.322 [INFO ] [internal.service.FeaturesServiceImpl] -     com.eclipsesource.jaxrs.provider.swagger/ (Wired to io.swagger.jaxrs/1.5.8 which is being refreshed)
2018-12-26 18:07:13.324 [INFO ] [internal.service.FeaturesServiceImpl] -     io.swagger.jaxrs/1.5.8 (Wired to reflections/0.9.10.v20160429-1435 which is being refreshed)
2018-12-26 18:07:13.326 [INFO ] [internal.service.FeaturesServiceImpl] -     reflections/0.9.10.v20160429-1435 (Should be wired to: com.google.guava/18.0.0 (through [reflections/0.9.10.v20160429-1435] osgi.wiring.package; resolution:=optional; filter:="(osgi.wiring.package=com.google.common.base)"))
2018-12-26 18:07:13.328 [INFO ] [internal.service.FeaturesServiceImpl] -     swagger-jersey2-jaxrs/1.5.8.v20160511-1038 (Wired to io.swagger.jaxrs/1.5.8 which is being refreshed)
2018-12-26 18:07:13.836 [INFO ] [internal.service.FeaturesServiceImpl] - Done.
2018-12-26 18:07:15.365 [INFO ] [javassist                           ] - FrameworkEvent INFO - javassist

When this occurs, devices do not respond to command for a minute or so. Also, when devices do work, there is a very large latency before a device will respond to a command, up to 10 seconds. Devices that are directly associated with another behave well, but anything controlled via rules is very slow. I added a log state to a couple of rules and when the rule is triggered, it is logged almost immediately, but the device will not respond for quite some time.

I’ve stopped OH and cleared the cache and restarted, but the behavior is the same.
Any ideas?

Have you tried rebooting OH, as this has helped others.

Yes, I’ve rebooted a few times.

“My Break-Dancing days are over, but there’s always the Funky Chicken” – The Full Monty

Silly me. Instead of using the openhabian-config to do the upgrade, I used apt. I did a purge and then used the tool to reinstall everything, restored from backup and I’m running fine now.

FYI, this is happening to me as well. I only see these log messages when turning the ROOT log to DEBUG, but it appears the system is trying to re-install the Swagger / REST Ui bundle over and over again. This results in the internal Jetty server being constantly restarted, which results in connections to your OH being inconsistent. I have uninstalled the 'REST Documentation" bundle in the meantime until I can figure out if this is an upgrade issue or something is wrong with the bindle.

1 Like

This was for me also the solution.
After I have remove the REST API documentation no more restarts of the bundle and connection time-outs.

It started also on my system after the upgrade to 2.4, so I guess there is something wrong with this bundle in this version

i have update my OH2 from 2.3 to 2.4 using update script for manual installation and have the same problem too. How i can remove REST API documentation?

Uninstall via PaperUI > Addons > MISC > REST API Documentation

1 Like

After the upgrade, the REST API Documentation is no longer under MISC for me. Under “User Interfaces” it appears “not installed”.

But I still get the error "Failed installing ‘openhab-misc-restdocs’ "

How can I remove it? I do not need it anymore!