[SOLVED] OH 2.3.0-1 Not responding after months of no issues

  • Platform information:
    • Hardware: Raspberry Pi 3 B
    • OS: Openhabian
    • Java Runtime Environment: ?
    • openHAB version: 2.3.0-1
  • Issue of the topic: please be detailed explaining your issue
    Recently OpenHab stopped responding to commands from devices. Tonight I tried accessing the web gui but no luck. I checked my router to make sure the IP didn’t change and it hasn’t. All I get from my web browser (Safari) is “Failed to open page”. I can ssh into openhabian though so there’s something.

I really don’t know where to start so any and all help is extremely welcomed.

On the ssh console use this:

sudo systemctl status openhab2.service

The output should tell you if openHAB is running or not.
If it isn’t running start it with:

sudo systemctl start openhab2.service


Thanks for the help but one of the things I tried before posting here was to update thinking that might have been an issue. Well, needless to say I royally screwed things up and just ended up re-install via the sd card image. I’ve got a simple setup so it wasn’t a big deal to do the re-install.

Next time I have an issue, hopefully I won’t, I’ll start with your suggestion rather than taking matters into my own hands.