[Solved] OH3 can't add equipment to a location

I wanted to start with building a new semantic model from scratch. I followed the documentation and had two problems (which might be related).

The model should be a location “house” within that should be “groundfloor” and within that is “office”.

When the type of “house” is location I can’t add anything to that item. The links to add location, equipment or points are missing.

If the type of “house” is group. It works.

So I set everything up as groups, not locations. Which is not nice and does not make sense but works somehow.

But then I can’t add equipment to office (Create equipment from thing). When I select the apropriate Thing, the window closes and I am back on the model page

This is correct.

A Location Item is one which holds latitude and longitude information. It is a real type of Item. These cannot hold other Locations, Equipment or Points.

A Location Group Item is what is known as a Location within the Semantic Model. It becomes most obvious when coding this in configuration files, but a Location Group Item is just a normal Group Item, with a little extra metadata to tell the Semantic Model that it is a Location that might hold more Locations, Equipment or a Point.

So, they are two different things, with unfortunately the same name! Confused enough?!

Try refreshing your browser (F5) or restarting your browser. There have been a number of reports of the UI doing something strange, but it clears up for a bit after a refresh…

Ok, got it.

And guess what, after restarting the browser everthing worked as expected.


This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.